SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
my 90 saab 900 turbo stopped running the other day..for the past two months I would be driving it,an the motor would shut down for a few seconds then start up again, would do this at idle,just stop, and it would start right up again..it would go for a week with no problems,then start doing it again....The other night i drove it home,turned it off....hasnt started since...fuel pump works,new fuel filter,plugs have good spark......any ideas? thanks mark
 

·
Registered
Joined
·
5,779 Posts
How was the idle before it became a no-start situation? It sounds like it could be a vacuum/air problem, possibly a bad AIC (automatic idle control). If you remove the hoses that are connected to the intake manifold one by one and suck on them, do any of them leak air? Also, inspect the intake piping for leaks.

When the car dies, what exactly happened? Was there a lot of black smoke/rich running smells? Check engine light?

It could also be something as simple as a bad connection at the battery or a bad ground, try cleaning all the important terminals with wire brush/sandpaper/needle file/whatever, and then coat with copper or dielectric grease to protect against future corrosion. The main engine ground is below the radiator bolted onto a crossmember towards the right side of the car.

Here is a general no-start troubleshooting guide: http://townsendimports.com/Web/engine_folder/nostart24.htm
 

·
Registered
Joined
·
1,320 Posts
When you crank it, can you smell fuel out of the exhaust pipe? Any error codes? I also second redbaron's comment on the connections; IMHO the connectors Volvo and Saab use suck. I've had seen quite a few Volvos that would not start because the pins in some connector would not be completely inside each other. :roll:
 
1 - 5 of 5 Posts
Top