SaabCentral Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
HI all - It seems I've been bitten by the TWICE Unit problem.

During a bad rainstorm I noticed the "Fasten Seatbelt" light illuminated while driving for no reason. I decided to investigate and found that clogged drains had caused water in the driver side and rear driver side to dampen the carpet.

I didn't have any other problems with the car, but decided to remove the drivers seat and investigate the TWICE unit for water damage before things go worse. It did not appear to have gotten wet on the surface.

I decided to open the TWICE unit once removed and inspect for moisture; I found several drops of condensation inside the case and slight water residue in a few places on the circuit board. Using electronics contact cleaner, I sprayed down those areas and it seemed to do the trick.

Hoping the issue was solved, I reinstalled the TWICE Unit into the car. It cranked over, started for a few seconds, then died. I tried again but all it would do is crank over. I disconnected and reconnected the battery hoping this would work - it did crank over, start, then stalled out. I did a scan for trouble codes and came up with P1460 (immobilizer active).

Does this mean my TWICE Unit is fried? When disconnecting and reinstalling the same TWICE Unit after cleaning, do I need to have anything reprogrammed?

I appreciate any advice on this one!!
 

·
Registered
Joined
·
675 Posts
Try the right 9-5 forum, this ones for post 2010 9-5
 
1 - 2 of 2 Posts
Top