SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
'02 9-5 Aero Wagon, '88 SPG, '02 Viggen Vert, '01 Viggen 4dr, +Triumphs & MGs
Joined
·
1,739 Posts
Discussion Starter #1
Hey all,

So my issue is this. My 2002 9-5 Aero has a hot weather issue. When it is over 83' out, the car gets sluggish, and if you are driving on the highway and go to pass, esp with AC on, it will throw an engine code and sometimes go into limp home mode.

Now what I have managed to track down, is that my cooling fans do not seem to come on. Not when driving, not when I stop the car...and shut it off. In fact this is my only Saab that the fans do not engage when the car is off. My friends 2002 aero...they do, another friends 2003....they do.

SO I checked out the operation of the fans - they work when I engage them with the tech 2, they work when I jump them. I changed the relays....and all to no avail. It seems like the computer for some reason never wants to trun them on?

I have reviewed a ton of threads, to no avail.

I did replace the temp sensor when I got the car....maybe a new one is in order?
 

·
Registered
Joined
·
7,897 Posts
What does the Tech 2 say the coolant temp is when the engine is hot? IF the sensor is bad the Tech2 will have the wrong number.

If you have one of those IR thermostats you can point it at the upper radiator hose and geta pretty good idea what the coolant temp is.
 

·
Registered
'02 9-5 Aero Wagon, '88 SPG, '02 Viggen Vert, '01 Viggen 4dr, +Triumphs & MGs
Joined
·
1,739 Posts
Discussion Starter #3
I will have to check what the Tech 2 says the temp is....sadly do not have an IR temp sensor....good thoughts - thanks!
 
1 - 3 of 3 Posts
Top