SaabCentral Forums banner
1 - 10 of 10 Posts

·
Registered
Saab 9-5 Estate 2004 Aero
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello

I've replaced my bi-xenon with bi-led.
Everything works fine - except i'm getting selfleveling error.
I bet it's because xenon bulbs are disconnected.
Xenon ballast is on it's place, just without bulb connected.

Is there a way to emulate bulb with some resistor ?
 

·
Registered
Joined
·
11,536 Posts
Hello

I've replaced my bi-xenon with bi-led.
Everything works fine - except i'm getting selfleveling error.
I bet it's because xenon bulbs are disconnected.
Xenon ballast is on it's place, just without bulb connected.

Is there a way to emulate bulb with some resistor ?
Is the system still self-levelling? Have you read the codes with a Tech II?

That warning light may be because the module detects that there is no working HID bulb attached. If it still self-levels (which is desirable), cutting the wire that turns on the warning light should turn it off.
 

·
Registered
Saab 9-5 Estate 2004 Aero
Joined
·
6 Posts
Discussion Starter · #4 ·
Don't have tech2 unfortunately.
I've found pinout of headlamp connector

1 - earth
2 - xenon dipping shield/flap
3 - 12v to xenon control box via dipped beam relay
4 - parking light
5 - goes to the instrument panel for levelling sensor warning light.
6 - levelling sensor connecting
7 - main beam feed. Connected to pin 2 inside the loom, outside the lamp unit. via bulb failure unit.
8 - not used.
9 - connected to the OBD2 connector under the dash.
10- 12v from fuse 21 in the end of the dashboard.

I bet it's enough to cut wire no 5.
Self-leveling does run on start, i mean it goes down-up, but i can't tell if it's working while driving.
Putting heavy load in trunk in garage will be good idea to check it ? :)

For sure it's working when i have bulbs connected
 

·
Registered
Saab 9-5 Estate 2004 Aero
Joined
·
6 Posts
Discussion Starter · #10 ·
1 - 10 of 10 Posts
Top