SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
My 9-3 has been sitting for a couple of years.
New battery so it cranks fine, and will start and run on aerosol-starter. So presumably spark is fine.

There is definitely fuel in the tank, as I just added a couple of gallons.
Does not fire and their is no smell of petrol.
Fuel Pump is not running.
Fuse and Relay are working.
Fuel Level sender is not working.
At Ignition-On, the there is a momentary flash of power to the fuel-pump plug, then nothing.
There is no fuel pressure in the injector rail
OBD reports no Fuel Pressure data.
This model has a fuel-pressure regulator, but as far as I can tell that's an emergency feature only, as it appears to dump fuel directly into the intake manifold.
I can't find any confirmation that there is actually a pressure sensor, and there does not appear to be one on the rail.
I have seen some mention of a pressure sensor attached to the tank???

any hints or suggestions welcome
 

·
Super Moderator
Joined
·
9,360 Posts
how do you know the relay is working if the pump isn't running..
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
how do you know the relay is working if the pump isn't running..
I think I need to get hold of a wiring diagram to fully understand what's going on.

the relay works, and I have even tried replacing it and bridging it. There is constant power there with Ignition on, but not at the other end.
 

·
Registered
Joined
·
3,192 Posts
bad fuel pump, tap strongly on the fuel tank while cranking and u might get it to start
 
1 - 7 of 7 Posts
Top