SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello all.

I have a 2001 9-3 Aero that's completly standard. I was driving yesterday and just on approach to some traffic lights, the engine cut out and refused to restart. The fuel tank was very low I must admit, so I filled a 5 litre container and poured it into the tank. The car then started but now refuses to idle. Also the TCS light and EML have stayed on. The car will drive but its obviously down slightly on power, not much, about 10% off the pace but down all the same.

I suspect myself that its a fuel pump. I'm getting a code reader on to the car this afternoon to see if that shines any light on it but I was just wondering do any of you guys know what it might be.

Thanks in advance, Ed.
 

·
Registered
Joined
·
21,583 Posts
I doubt that it is the FP (fuel pump).
The "new era maintenance items are the FP and the CPS, good for 100 to 200K miles.
At least have the throttle body cleaned, if not rebuilt.
 

·
Registered
Joined
·
21,583 Posts
Even though the FP and CPS are "new era" maintenance items, good for 100 to 200K miles, I seriously doubt that the problem is the FP.
These throttle bodies are troublesome; maybe they should be rebuilt every so often.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
Guys thanks a bunch. You were bang on the money. Fault code reader brought me staright to the throttle body but even after I'd wiped the fault, the problem still reaccured. Thats were the youtube clip put me right. I reset the throttle body, cleared the fault codes again and bingo, all was well again. I've also replaced all the vacume pipes which were all cracked and clearly leaking. This could have been the reason that caused the original fault.

Anyway all is good now again and I've purcahsed a code reader from E-bay. Thanks again guys and regards from Ireland.

Ed.
 
1 - 5 of 5 Posts
Top