SaabCentral Forums banner
1 - 20 of 55 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello to everyone on Saab Central!
I am a new member here and looking for some help with my new wonderful SAAB i purchased!
I have just purchased a 1989 900 Turbo.
Its 5 speed manual with all the luxury.
Car has done 300, 000km and the engine needs some Attention!

This is where the fun starts for me, and hopefully a small re-build.
The car has a aftermarket performance exhaust, and also an aftermarket mid size FMIC inter cooler. - Yay, saves me doing some more work.

There is a ratteling sound on cold start up, Timing chain? There is a bit of play.





The Turbo also has a tiny bit of play in the shaft, I can move it with my fingers a bit up and down..



Many of you do a lot of work on these cars,
So what do you recommend me doing to this engine?
I want it running all reliably, no noise nice and tight and good boost.
I would like some decent power.

I don't know where to start, I am capable of doing most work myself.

Thanks to all for helping me with my new 900 Build up!
Joey
 

·
Registered
Joined
·
18,382 Posts
Welcome aboard.

Your car isn't red by any chance?
It sure looks red!! :lol::lol: This is going to be fun!

I guess the biggest question is, does it run right now?
 

·
Registered
Joined
·
406 Posts
I sure hope not
well, his did have 300 K on it (as seen from one of his stupid youtube videos http://www.youtube.com/watch?v=7xAE2WeJQoU )


and he does have a small FMIC, and probably a performance exhaust, and it is 1989, and its red, and its in the same country (there cant be all that many red, 1989 Saab 900 Aeros with 300 ish K. a FMIC and a performance exhaust in Aus, can there?)
 

·
Registered
Joined
·
1,216 Posts

·
Registered
Joined
·
834 Posts
OP> Just do a search for every post made by "mmustillo" and you will soon learn about the complete history of this car! Good luck

sab
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #13 ·
Engine Specs!

Wow!

So many replies already, but none have answered my technical questions about the build up. - I was hoping for some Tech Help (not discussing car colors) - ' May I ask why is my thread being over taken buy someone else's 900? '

Where can I seek for some technical help?

The car drives nicely, The Tranny feels very strong - Thats a good sign!
Engine feels nice and strong, But it is making a few noises and before i drive it more I want to fix it all up to prevent future damage.
I understand a bit about internal combustion engines but I have never owned a Euro Car. Just Ozzy V8's down under here :)

Hope to get some help from you guys.
 

·
Registered
Joined
·
281 Posts
as to your "technical questions" .......

rattling sounds, change the oil first see if that helps, most likely the lifters
that head looks too clean to have 300km on it:confused:

turbo, If it don't smoke then leave it alone!


They all are bustin your balls 'cause the previous owner of "supposedly" your car said he sold it to a wrecker for 150 bucks:p
 

·
Registered
Joined
·
10,081 Posts
' May I ask why is my thread being over taken buy someone else's 900? '
It isn't somebody else's. It's your car (with the previous owner) that we're discussing...

Where can I seek for some technical help?
Right here.

There's a few threads on replacing the timing chain - it's not that bad a job, if it goes right. If it goes wrong, then it gets big quickly.

To check for play in the chain, you need to remove the spring from the tensioner (behind the aircon compressor), remove the tensioner, and measure how far it's protruding.

As for the turbo - if there's just a little movement, then I wouldn't worry about it. If it smokes badly on boost, then it might be worth thinking about getting it reconditioned.
 

·
Registered
Joined
·
10,081 Posts
I hope it is Matti's car, atlease then it was saved...
Indeed. I never did think he'd actually scrapped it. What sort of pillock would do that, just because they couldn't get the full asking price they were after? <shrug>

Still, I hope his M1 doesn't end up with wheels that don't fit and a shopping list on the door. 900T16V - have you removed those silly stickers? Please tell us you have...

Anyway - that YouTube vid... It sounds tappet - a good oil flush won't hurt it. Might be worth taking the oil feed bolts to the cams out - they're the black ones, and should be on the spark plug side of the cam caps. Remove them, one by one, without touching the outer bolts. Make sure the passages in the bolts are clear.

The Bentley manual suggests bleeding air out - all the bolts in and tight except the black one from no5, loosened three or four turns - 5 is the intake, furthest from the chain. Then cover back on, ignition disabled by unplugging the ignition amplifier, and churn it on the starter for 15sec, wait 30sec, repeat two or three times - then cover off and make sure there's oil passed the bolt head.

Let's hope there's no lasting damage been done to the car. It should all be easily undoable, I hope.
 
1 - 20 of 55 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top