SaabCentral Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
7,033 Posts
Discussion Starter · #1 ·
1982 non APC turbo, cuts out under hard boost at around 3500 RPM. Have fixed vacuum leaks, exhaust header leak already and it holds boost better, but still cuts out. Existing tiny oil leak from (dizzy, turbo oil line or valve cover) could this be an issue or should I now address the waste gate?

Cheers from holiday land!
 

·
Registered
Joined
·
1,550 Posts
Hi , I thing you may loosing pressure between the turbo and intake . Check the silicone pipe coming out of the turbo to the intake for splits. also be shure the coil wiring connectors are not coroded.You might want to swap out the coil wire to the dizzy wire also as a precaution.I have had problems with all of the above.:lol: Enjoy that new sweet 8 valve man !!! :cheesy: Pat
 

·
Registered
Joined
·
5,464 Posts
I would say its probably a vacuum leak or a loose conection on one off the intercooler/turbo hoses.

I had the same problem on my 88 T when I first got it, around 3-4K it would cut out or kick, I'd have to shift and repeat it all over again around 3-4K.

I had to replace all the vacuum hoses and take all the hoses and piping off and tighten them one by one as I put them back on. I found several that were either not conected properly or were had slipped off a bit. There isn't much space on them, if you put one side on too far then when you tighten the other side on it usually doen't seal off right, at least in my experiance.

Have fun, I'm going to go pull the head off of mine, :D

Cheers
 
1 - 3 of 3 Posts
Top