SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
168 Posts
Discussion Starter #1
Okay, my background:

2007 Saab 9-5 Sedan (base model) with 62000 miles

Me? Stupid kid who loves his car.

Engine codes:
1300
1181
0507
0336

Symptoms:
-No starting after hot.
-Limp mode was set off and after codes were cleared, it was turned off.
-Jolting at times while driving. Today I found out that directly after a jolt, I lose my power brakes. (They resume seconds later.)

Other info:
My Brake Booster Vacuum Hose was broken at the one way/check valve towards the back of the engine when a friend installed a new heater control valve for me.

My Thesis:
I assume that I definitely need a new vacuum hose. I read that 1181 is a vacuum leak. Next I think I need a CPS because of 0336 and 1300. However I have no idea what 0507 is.

Summary:
I'll order parts Friday when I get paid. I'm posting this for those who might have a similar problem and to see if I can get any more advice on this manner.

Thanks y'all!
 

·
Registered
Joined
·
2,225 Posts
Sounds like you're on the right track. In the FAQ section there is a list of codes, 0507 is idle control system RPM higher than expected. When you clear up any vacuum leak that might may be causing higher RPM's that should theoretically fix this code also.
 

·
Registered
Joined
·
168 Posts
Discussion Starter #3
Thanks LEP3! I wanted to make sure I was headed in the right direction. I'm going to look for those engine codes just so I can bookmark them.

Thanks again!
 
1 - 3 of 3 Posts
Top