SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
142 Posts
Discussion Starter #1
Tonight after work driving home all of a sudden my radio stopped working and the blinkers make no sound. So I check the fuses and the # 22 in the trunk(Rear Amp) was blown as soon as I replaced it...it blew again...So I am assuming the Amp is shot now?

Checked the fuse 14 in the fascia, Its okay.

If you could help that would be great thanks.
 

·
Registered
Joined
·
5,446 Posts
Tonight after work driving home all of a sudden my radio stopped working and the blinkers make no sound. So I check the fuses and the # 22 in the trunk(Rear Amp) was blown as soon as I replaced it...it blew again...So I am assuming the Amp is shot now?

Checked the fuse 14 in the fascia, Its okay.

If you could help that would be great thanks.
Sounds (silent) like it. Pull the connector off the amp, be careful of fiber optic connector. Check for instructions here or saabdocs.com. If the fuse does not blow with amp disconnected I would agree that amp has failed.

http://www.saabcentral.com/forums/showthread.php?t=242695
 

·
Registered
Joined
·
142 Posts
Discussion Starter #3
Sounds (silent) like it. Pull the connector off the amp, be careful of fiber optic connector. Check for instructions here or saabdocs.com. If the fuse does not blow with amp disconnected I would agree that amp has failed.

http://www.saabcentral.com/forums/showthread.php?t=242695
That really is a bummer...Its a little cold right now but when I have a chance I will do that, Where would be a okay place to find an amp? Ebay?
 

·
Registered
Joined
·
142 Posts
Discussion Starter #5
I found one on car-part.com for $100 in August.
Okay I am thinking its my rear amp, maybe my front. There was a brunt smell in the trunk when i opened it and even stronger in the fuse area so my guess is the rear but I will be testing later...Two job and school keeps a college student busy
 
1 - 5 of 5 Posts
Top