SaabCentral Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hey guys,

I am new to the Saab Central and to Saab stories all together... lol
I am a big ecotec fan and picked up a 2010 9-3 2.0T for $3k, 227k miles but one owner and garage kept.

Anyway when i first got it (Jan 2019) I noticed if i held the peddle down in high gear (when i have should been in lower gear) I would get a small misfire. Out of the blue it went from barely happening and in small tiny misfires to (3 months later) doing it in all gears and substantially worse. I could hold the peddle down and get the code. so i checked: cylinder 1 misfire. swapped 1 and 4 coils and then it said cylinder 3... weird..

So im thinking coils... well before i changed the coils i changed my plugs and they were shot (almost like rusty and some electrode melt. some would say looks like running lean). put the new plugs in and bam! seemed perfect. well few days later it was doing the same thing when i got it, small short tiny misfires. Well yesterday i was driving and it started to misfire bad again.

I put NGK double platinum plugs when i changed them...

Thoughts? Coils? Upgrade to Iridium plugs? Lean condition?

Thanks guys!
 

·
Super Moderator
Joined
·
19,621 Posts
Bad coil(s).
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
Update: I changed the coils. All good now! Thanks guys!

I have a separate issue with my XWD, maybe you guys can help. Here is a link to the thread, im the last post. I am having similar issue a the original thread poster but repaired module and continuity check on my rear wiring harness has yielded nothing... :
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
Nah, I wanted the NGK coils but they are like $180 a pop... So I got the $40 SPP's cuz I wanted to make sure first. O will be getting the NGKs asap now... Thanks man
 

·
Super Moderator
Joined
·
8,667 Posts
The B207 engine only uses oem coils ANYTHING else will give you problems..

Hence the COIL sticky at the top..
 

·
Registered
Joined
·
19 Posts
Discussion Starter #10
10-4! Don't know sticky you are referring to... But I will take your word for it and get on getting the oems asap. Thanks again guys. If you guys don't mind can you take a look at the thread I mentioned above about my xwd issues. I've hit a new dead end and am in desperate search for some new avenues to explore...
 
1 - 10 of 10 Posts
Top