SaabCentral Forums banner

1 - 20 of 24 Posts

·
Registered
2010 9-3 2.0T
Joined
·
13 Posts
Discussion Starter #1
Very odd occurrences with my Saab recently.

My turbo is starting to go, this is known. Oil is leaking into my downpipe & I have a new turbo already I just need to put it in. However, 3 days ago I was driving home and going roughly 60-70 and my car suddenly filled with white smoke. since then, I’ve had very hard shifts. Most noticeably when putting it into drive or reverse. It waits almost a full 5 seconds at times and then slams into the gear with a jerk. yesterday when I was driving it started to slip and rev really high without any power (as if it was in neutral) and then jerk back into a gear. After doing this twice in a row my car was stuck in 5th gear. After slowing down to 10 mph, my car jerked down into 2nd. But that was it, only second and 5th. (My check engine light came on for the first time around then, as well as a limited performance warning) - as of today, the check engine light has been off, same with the warning. And I’ve had no issues changing gears while driving, but I still have that wait and jerk when I put it in drive from park. Any ideas what could be happening?
 

·
Registered
Joined
·
1,357 Posts
Get a Tech 2 scan for DTCs. 2/5/R gears only is limp home mode because of TCM fault.
278040

EDIT: add WIS limp home description
 
  • Like
Reactions: ep9-3

·
Registered
2010 9-3 2.0T
Joined
·
13 Posts
Discussion Starter #3
Get a Tech 2 scan for DTCs. 2/5/R gears only is limp home mode because of TCM fault.
View attachment 278040
EDIT: add WIS limp home description
I’ve got to invest in a tech 2 I guess. Seems real handy, a DCT is what exactly? Sorry this is my first car and I’ve got a bit to learn

thank you for the help!
 

·
Registered
Joined
·
2,957 Posts
This is a 5 or 6 speed xwd ?
when was the last time u changed ur ATF and what brand of ATF was used and did u check ur ATF level recently ?
 

·
Registered
2010 9-3 2.0T
Joined
·
13 Posts
Discussion Starter #8
This is a 5 or 6 speed xwd ?
when was the last time u changed ur ATF and what brand of ATF was used and did u check ur ATF level recently ?
5 speed auto FWD. Bought the car at 127k and I’m at 145 now. Never touched or looked at ATF. Doing that today, going to see if I can top it off
 

·
Registered
2010 9-3 2.0T
Joined
·
13 Posts
Discussion Starter #10
Check its condition, if it doesn't look right, flush it And dont just top it
transmission fluid was black & smelled burnt. Going to be changing it as soon as possible - hoping this is the cause of everthing. If not, transmission solenoid?
 

·
Registered
Joined
·
2,957 Posts
Flush one time as per WIS .. that would do it .. use only OE or equivalent fluid like the Toyota T-IV ..
Other than that, will do a couple of checks, but mostly it ended up being the torque converter
 

·
Registered
2010 9-3 2.0T
Joined
·
13 Posts
Discussion Starter #13
I've got a 2010 9-3 2.0T, FWD Automatic

I've been having an issue with my transmission. It shifts into Drive/Reverse hard, and will also sometimes slip under acceleration.
This causes it to go into limited performance mode.
I changed the transmission fluid, and it seemed to get slightly better when putting into reverse/drive, but still slipped gears a little and then went into limited performance mode on my ride home.

Do you guys think that replacing my TCM would help with this? and if so, could you point me in the direction of which one I should buy? I want to be able to use my paddle shifters

It seems like I need some tech 2 work done with the TCM too before I can install it?
 

·
Registered
2008 Saab 9-3 Aero FWD 6MT
Joined
·
148 Posts
What condition was the fluid in? How long has it been having problems? Any codes? Next step is definitely Tech2. Don't replace until you diagnose.
 

·
Registered
2010 9-3 2.0T
Joined
·
13 Posts
Discussion Starter #15
What condition was the fluid in? How long has it been having problems? Any codes? Next step is definitely Tech2. Don't replace until you diagnose.
The fluid was black but no metal or anything. Problems are recent, started happening and then the 2nd day I put it in the shop and haven’t drove it since.
It has a check engine but when I checked the code it isn’t a valid DTC (p0741)
 

·
Registered
2008 Saab 9-3 Aero FWD 6MT
Joined
·
148 Posts
You need a better scan tool, preferably a Tech2. okcrum is right, usually this can be caused by low/poor quality fluid or the solenoid itself. This can cause poor shifting, or if an intermittent problem, the constant locking and unlocking of the converter, causing a "bucking" or "jerking".
 

·
Registered
Joined
·
489 Posts
The WIS troubleshooting for the code basically says to check the fluid first, then input and output speed sensors. If those are all good then the trans is bad.

It could be slow/sticking linear solenoids but I think that'd be rare on a 2010 as most of the valve body gremlins were worked out of the 5-speed by then.

At this point a full flush using new 3309 wouldn't hurt.
 

·
Registered
2010 9-3 2.0T
Joined
·
13 Posts
Discussion Starter #19
Thank you guys all for the input! I really appreciated it. I can’t quite do a flush but I’m going to be doing 3 full changes with Mobil 3309, hopefully It’ll get a little better from these. Next step is to check the input and output speed sensors? and possibly the solenoid?
 
1 - 20 of 24 Posts
Top