SaabCentral Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello. Never posted here so if I forget some info forgive me. I have a 2009 9-3 2.0T XWD and I've had p2431 (SAI air flow/pressure sensor/perf bank 1) and P0411 (SAI incorrect flow) codes for a while, I clear them and they come on in a week or so. With my inspection coming up which requires emissions I'm desperate at this point. In the past I replaced the valve on top of the engine because it was filled with soot, which helped for a while. Then when the light came on I replaced the SAI pump. I'm not sure what to do next and have done a lot of reading on this topic but most people just say to replace the valve which I already have. Any help will be great and don't really want to take it to a shop until I find out what it could be. Thank you
 

·
Super Moderator
Joined
·
19,646 Posts
Timing for these events?
When you bought car.
When you first noticed codes.
When you replaced valve.
When you replaced pump.

Have you given it ample time (100 miles or so) since replacing the pump?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Bought the car about a year ago, was getting the codes shortly after. I replaced the valve probably 4-5 months ago, pump 2 months ago. after I clear the codes they come back in around a week and I drive about 1000+ miles a month for commuting. the car has just over 145k total miles
 

·
Super Moderator
Joined
·
19,646 Posts
I doubt new valve failed already but have you checked it for soot?
 

·
Super Moderator
Joined
·
19,646 Posts
Aleo, safe to assume these were new parts?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Havn't checked again for soot because it was a new pump and I don't think that it would be full of soot again because both parts were new.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
thank you for the help, I actually replaced that too but had just forgot about it haha. I've just put a lot of time into fixing this problem. After some more research the past couple of days I read some people were saying to replace the o2 sensors so that was next on my list i guess
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
thank you for the help i appreciate it. but I went to a junkyard and got a fuse and a few relays out of an older saab to swap in my car and the lights out now. When i leave work tonite ill see if i can hear the pump working. Bit if it something happens ill keep you posted. again i really appreciate it.
 
1 - 9 of 9 Posts
Top