SaabCentral Forums banner
1 - 20 of 20 Posts

·
Registered
2008 9-3 linear 2.0t Automatic
Joined
·
13 Posts
Discussion Starter · #1 ·
Hi everyone I have been having an ongoing issue replacing parts to try resolve my issue I have replacing the sim cim bought new keys replaced battery and still having the issue there is no longer dtc codes appearing for the cim module and I am wondering what I should do next as I am lost. The steering wheel isn’t locked and I’m not sure if this is due to the car not moving. I can turn the key to start where it was not turn back by itself and the lights will switch off however if I turn it to start again nothing will happen with the lights and the key will turn naturally, the car says check ok besides on time I saw it say something about the convertible roof not being in a detectable position and to fix it before starting car and wondering if this is the issue.
 

·
Registered
Joined
·
14,244 Posts
Did you marry CIM and new keys (fobs) to car with TECH2?
What was DTCs (post code itself, not what reader think what it means)?
 

·
Registered
2008 9-3 linear 2.0t Automatic
Joined
·
13 Posts
Discussion Starter · #3 ·
Yes the cim and keys were married with a tech 2 before replacing the cim I have about 5 codes in the cim which I can’t remember exactly what they were besides cim internal fault and k line short to open
 

·
Registered
2008 9-3 linear 2.0t Automatic
Joined
·
13 Posts
Discussion Starter · #6 ·
Did a bit more digging through the tech 2 and found where the scl is in programming upon opening this it says there is a dtc code and steering column malfunction appears on sid by this I’m guessing I’m going to need to replace the scl aswell
 

·
Registered
2008 2.0 9-3 Linear petrol Automatic/Manual
Joined
·
63 Posts
Need to be a little clearer with your issues and you will get great help here.

Codes/bullet points/start with what’s the problem. Keep it short and sweet 👌

Maybe rephrase your original post and add in the codes, I personally cannot fully understand what the problem is apart from the car isn’t starting with fob? Correct?

I find everyone gets the answers they’re looking for on this forum if they have run tech2 first. Not putting you down by the way but the first constructive step in this scenario is to be a little more clearer 😌
 

·
Registered
2008 9-3 linear 2.0t Automatic
Joined
·
13 Posts
Discussion Starter · #9 ·
Sorry I’m currently working and I’ll try to summarise as quickly as I can, not mentioned earlier but I am getting 7 codes from the acm these are for all four pillars saying faulty communication and 3 airbags that are shorting to ground. Besides this the car isn’t showing any more codes after replacing ism and cim and the key will move through lock off on. The steering wheel is always unlocked and upon turning the car into the start position there is a single click sound and all the cabin lights + radio lights turn off and the key stays in start (doesn’t move itself back to on) however turning it to start again there is no dimming of lights and the key will turn itself back to on. I have tried jumping the starter relay where the engine will crank but won’t start. The car also seems to be meeting all requirements to start when looking at the tech 2 in the starting section.

summary
Cim + ism replaced and married
2 new keys married
Car won’t crank and lights turn off in cabin upon first turn into start
Won’t replicate this trying to turn it to start again unless car is turned off then on
Airbag malfunction + 7 dtc codes for airbags
Can crank by bypassing straight to starter relay (r7 I believe) but still wont start


also to note bought the car not running and it came with two acm that don’t seem to be doing anything different (have married after changing out)
 

·
Registered
2008 9-3 linear 2.0t Automatic
Joined
·
13 Posts
Discussion Starter · #10 ·
Sorry I’m currently working and I’ll try to summarise as quickly as I can, not mentioned earlier but I am getting 7 codes from the acm these are for all four pillars saying faulty communication and 3 airbags that are shorting to ground. Besides this the car isn’t showing any more codes after replacing ism and cim and the key will move through lock off on. The steering wheel is always unlocked and upon turning the car into the start position there is a single click sound and all the cabin lights + radio lights turn off and the key stays in start (doesn’t move itself back to on) however turning it to start again there is no dimming of lights and the key will turn itself back to on. I have tried jumping the starter relay where the engine will crank but won’t start. The car also seems to be meeting all requirements to start when looking at the tech 2 in the starting section.

summary
Cim + ism replaced and married
2 new keys married
Car won’t crank and lights turn off in cabin upon first turn into start
Won’t replicate this trying to turn it to start again unless car is turned off then on
Airbag malfunction + 7 dtc codes for airbags
Can crank by bypassing straight to starter relay (r7 I believe) but still wont start


also to note bought the car not running and it came with two acm that don’t seem to be doing anything different (have married after changing out)
I will post all the codes the car is pulling when I get home from work but hoping someone can help me out with this information as I am running out of ideas and thinking there is a wiring issue somewhere
 

·
Registered
2008 2.0 9-3 Linear petrol Automatic/Manual
Joined
·
63 Posts
Yes put codes when you can don’t worry you’ll get the help. If possible, throw up a quick video of turning the ignition. Just to to be sure - the car is cranking just not starting? You’re not getting a “tick tick” noise under the hood or anything like that?
 

·
Registered
2008 9-3 linear 2.0t Automatic
Joined
·
13 Posts
Discussion Starter · #12 ·
Yes put codes when you can don’t worry you’ll get the help. If possible, throw up a quick video of turning the ignition. Just to to be sure - the car is cranking just not starting? You’re not getting a “tick tick” noise under the hood or anything like that?
The car has no crank no start only indication of it going into start is the cabin lights turning off I’ll post a video of it soon along side all the codes the only way I could get the car to crank was through bypassing the starter relay and the car still wouldn’t start only crank. Meaning to me the car isn’t getting power to the starter relay or isn’t allowing power to go to the relay
 

·
Registered
Joined
·
14,244 Posts
I'd check NSS and H24-2 connector under battery.
That click is +15 relay. It should click when you turn ignition ON.

Have you fully charged/replaced car battery?
 

·
Registered
2008 9-3 linear 2.0t Automatic
Joined
·
13 Posts
Discussion Starter · #17 ·
I'd check NSS and H24-2 connector under battery.
That click is +15 relay. It should click when you turn ignition ON.

Have you fully charged/replaced car battery?
Yes the battery was replaced when I purchased the car is is on a trickle charger most of the time as the battery died at one stage after the car was sitting for a month
 

·
Registered
2008 9-3 linear 2.0t Automatic
Joined
·
13 Posts
Discussion Starter · #19 ·
So you have bad battery that you tried to "wake up" with external charger.
No I have a new battery that died which now that I think about it could have been caused by something draining it when the car was off? The battery is on a trickle charger just to ensure it’s fully charged when I go to diagnose
 
1 - 20 of 20 Posts
Top