SaabCentral Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi Folks,
Newbie here I hope somebody can help?
So to save the usual its the CPS, its the MAF I'll start with what I've done thus far:
1) Dismantled and cleaned MAF + all air intake system
2) Fitted (Another) new Bosch OEM Air Filter
3) Disconnected, cleaned & checked associated harnesses and connectors
4) Fitted new Bosch OEM CPS
5) Fitted 4 x NGK OEM Spark Plugs (had Denso iridium's which I fitted 14 months ago)
6) Tested all 4 Coil packs
7) Dismantled, Cleaned Throttle body
8) Fitted new Bosch OEM fuel pump relay
9) fitted (another) new Bosch OEM Fuel Filter
10) 3 x Full diagnostic/ code finding checks on 2 different sets on advanced equipment (Not hand-held)
There are no codes stored and EML has never appeared, all warning (Saab in-car computer, settings, warnings etc. function perfectly)
My problem: Once fully up to temperature + approx 5 mins or more, stopping i.e. Junction, traffic lights , parking she can cut-out. She ALWAYS re-starts instantly with a single turn of the key, once this has happened it will not cut out again for at least 3-4 further stops, this can happen 2-3 times if out driving for an hour or so, alternatively once restarted (first time) it may not happen for another 4-5 days motoring??? Apart from this she still runs/performs perfectly.
Mean anything to anyone?
Lord Sausage
 

·
Registered
Joined
·
2 Posts
Hi Folks,
Newbie here I hope somebody can help?
So to save the usual its the CPS, its the MAF I'll start with what I've done thus far:
1) Dismantled and cleaned MAF + all air intake system
2) Fitted (Another) new Bosch OEM Air Filter
3) Disconnected, cleaned & checked associated harnesses and connectors
4) Fitted new Bosch OEM CPS
5) Fitted 4 x NGK OEM Spark Plugs (had Denso iridium's which I fitted 14 months ago)
6) Tested all 4 Coil packs
7) Dismantled, Cleaned Throttle body
8) Fitted new Bosch OEM fuel pump relay
9) fitted (another) new Bosch OEM Fuel Filter
10) 3 x Full diagnostic/ code finding checks on 2 different sets on advanced equipment (Not hand-held)
There are no codes stored and EML has never appeared, all warning (Saab in-car computer, settings, warnings etc. function perfectly)
My problem: Once fully up to temperature + approx 5 mins or more, stopping i.e. Junction, traffic lights , parking she can cut-out. She ALWAYS re-starts instantly with a single turn of the key, once this has happened it will not cut out again for at least 3-4 further stops, this can happen 2-3 times if out driving for an hour or so, alternatively once restarted (first time) it may not happen for another 4-5 days motoring??? Apart from this she still runs/performs perfectly.
Mean anything to anyone?
Lord Sausage
I had symptoms similar to this that ended up to be snapped timing chain guides. Check out this thread:
...threads/timing-chain-question-2nd-opinion.512361/
Good luck!
mediadude
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
I had symptoms similar to this that ended up to be snapped timing chain guides. Check out this thread:
...threads/timing-chain-question-2nd-opinion.512361/
Good luck!
mediadude
TBH I hadn't considered this? Again with my situation i.e. the numerous cut-outs and the parts I've changed + hard re-boot I would have seen one light or a code, but no! Worth adding this is a very low mileage car, genuine under 60k! Finally I can't see to follow/open your link, Is there a trick I need to know with this forum?
Lord Sausage
 

·
Registered
Joined
·
2 Posts
TBH I hadn't considered this? Again with my situation i.e. the numerous cut-outs and the parts I've changed + hard re-boot I would have seen one light or a code, but no! Worth adding this is a very low mileage car, genuine under 60k! Finally I can't see to follow/open your link, Is there a trick I need to know with this forum?
Lord Sausage
No trick with the forum except that they don't allow links for first posters. Just add the saabcenrtral dot com url to the beginning of the link and it should work.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
Try as I may ….every combination I can think of, this will not open? BTW what model is/was your Saab: Year , engine etc.?
Regards
Lord Sausage
 

·
Registered
Joined
·
27 Posts
It’s only a partial url so you have to add the forum part of the link. Try this one.

Linky

My 9-3 has a similar issue. Started off as a stall when I came to a stop or slowed for a turn. It now stalls just sitting and idling. Yours starts up right away, mine has to sit for 30-60 seconds before it runs again. Fires right up after sitting, before that it just keeps cranking. Not the CPS or MAF. Fuel relay physically looked okay but didn’t test it other than resistance.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
Hi 93Gator,
I'll try the link albeit I cannot think it could be anything to do with the timing gear as the engine runs silently!
No noise from the chains etc. Incidentally mine can idle perfectly for as long as I like, the cut-out only happens in-between slowing from say 5mph to a stop???? Not happened for three days this week though it did on Monday?
 

·
Registered
Joined
·
27 Posts
Yes, I would agree don't think mine is timing chain related either. I would think the car would throw a CEL with the P0300 code for misfires if the chain stretched enough to cause a stall. Mine started off as slowing stall, and had a neighborhood mechanic look at it. Wouldn't stall for him. Once I picked it up it stalled again coming to a stop then progressed to stalling at idle.

With the stall at slowing I thought it could be a vent line issue to the brake booster, but the lines looked okay and booster seems to be working well. With your list in your original post the one thing that catches my eye is that you cleaned the MAF. Maybe you can try wiggling the wires and tapping on the sensor to see if that causes the engine to stumble. Maybe you have a loose connection inside the MAF and that's why it's intermittent.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #9
Hi and thanks for the correspondence, it seems to have baffled everyone over here! MAF and every harness with a connector that I've dismantled and those in close vicinity I've cleaned and checked, however I will try what you've said! Today I've driven for over 2 hours, in traffic jams, in town and stopping numerous times and it didn't happen at all!
One thing with the MAF though, on dismantling I noticed the o ring had stretched, I was able to get it all back together and I doubt if its an issue? The other thing I did read somewhere was there is a harness under the battery which feeds the throttle body, this allegedly can be suspect and it is one I've not looked at yet? I'm loathe now to touch anything while it seems to have stopped occurring!
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
Hey 98Gator,,,, I think you've given me the best clue yet! Unfortunately albeit things improved they've not gone away: No longer cutting out completely, however the revs drop off fast as before only not at the same lightning speed, they drop down to around 600-650 RPM and bounce back up to idle! Now here is the clue: It always happens when applying firm pressure to the brake pedal (Never realised this before!) So I visually checked the brake booster and the two small vacuum pipes, cleaned the connector and the frequency of cut-outs (actually now RPM drop-off) is less, but not eliminated..... could this be my problem? maybe replace the booster (Valve), pipes? Finally as my problem is almost a year old I've gone though everything I have replaced during this period and I'm pretty sure things escalated just after I replaced the front pads....another clue?

Lord Sausage
 

·
Registered
Joined
·
14 Posts
Discussion Starter #11
Apologies.... I'm referring to
Turbo Charge Air Boost Pressure Control Valve.... sorry for confusion!

Lord Sausage
 

·
Registered
Joined
·
14 Posts
Discussion Starter #12
Ah translation confusion on my part!!!! I think my problem may be related to the Brake Servo (Booster in USA!) and/or the vacuum pipe....possibly?
The air boost pressure control valve was just another component with vacuum and a power connector I cleaned and re-fitted. The newly established common denominator here is the cut-outs.... now RPM drops occur when coming to a stop with the footbrake applied, however as before the fact that this is so intermittent and random if/when it repeats itself just makes this such a mystery!

Lord Sausage
 

·
Registered
Joined
·
14 Posts
Discussion Starter #14
Hi Mimmi,
I have come to the same conclusion, however why only when warmed up, why it does not happen for several subsequent stops ….even 3-4 days?
I've visually looked at the pipe except the section behind the bulkhead heat shield and it looks perfect and the brakes ABS etc are excellent? Also I can't make it happen.....i.e. random hard braking at various speeds and on tick-over/idle cold through to totally hot?

Lord Sausage
 

·
Registered
Joined
·
159 Posts
Whenever there is random behavior like this I say replace the battery just to make sure. A weak or borderline battery doesn't throw a distinct code and can cause all kinds of odd behavior from my experience. I think it's a worthwhile step.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #16
Thanks Thomcat,
The Battery is a very heavy duty 5* unit under 3 years old, always gives minimum of 12.4 v on starting after static for several days, so unlikely...… I think????
 

·
Registered
Joined
·
159 Posts
It's happened to me on a previous 9-3 (i forget if it was an aero 2.8 or the 2.0 engine) and the engine would cut out seemingly randomly occasionally over a period of a few weeks. I took it to the mechanic's and they tested the battery and they said it was strong and fine and provided good/consistent current. After the third time it happened I replaced the battery and it stopped happening. I brought it up because I know the 2.8 engine compartment runs hot and tends to shorten battery life in general.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #18
Much appreciated Thomcat, as I've said many times this problem is so very odd in respect of the random frequency albeit there are many similar stalling and cutting out issues on Saabs I've now discovered, therefore anything shared can only be helpful to me! The engine compartment does indeed get very hot and although I've still not gone over 60k miles she's 12 years old and many of the plastic/nylon fittings have now gone brittle! In regard to the battery because my issue only happens after the engine is fully warmed up, the battery is fully charged and even with Air-con on, seats heating, lights blazing she starts first time so I know there's around 14.4 + volts running when it cuts out??? However I am almost out of ideas and parts suggested to replace now!
Shall investigate the brake booster pipe closely at the weekend

Lord Sausage
 

·
Registered
Joined
·
14 Posts
Discussion Starter #19
Checked the complete vacuum system.... but found no leaks, loose fittings, zilch! Furthermore I've resorted to deliberately trying to force a cut-out by heavy braking, sudden stops from various speeds, on the flat, up a gradient, downhill both before and after the usual 5 mins or so post being fully warmed up! The hardest aspect to understand is the frequency after the initial cut-out, which can be as little as three more stops or four days commuting this throws any logic out the window!
On the UK Saab site the ignition barrel was suggested as a problem? I do know the ignition module/ key switch behind the gear stick is known for a few issues, but again still doesn't make sense.....yet more parts to dismantle....hey ho!
 

·
Registered
Joined
·
14 Posts
Discussion Starter #20
Update!!!! None of the above......pretty certain I now know the problem, something I toyed with 7 months ago! Did plenty of research then and again recently, but no links/threads whatsoever? It is one of two problems related to another component! I'll keep my powder dry until I've completed a weeks worth of driving as I'm certain I can avoid the issue by driving differently..... clues are within the situation/circumstances when it occurs and the elimination of other potential problems.

Lord Sausage
 
1 - 20 of 22 Posts
Top