SaabCentral Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
643 Posts
Discussion Starter · #1 ·
First off the car is driving just fine, as normal, however I have the damn CEL on and it says code P0089. I have no other codes.

Now this is Fuel Pressure Regulator referred to fuel pump which is a common issue I guess with the aeros.

I have tightened my gas cap and flashed it twice but the CEL comes on every time after about 30 miles.

it is NOT intermittent on and off.

I am going to try a 20 gallon techron cleaner today to really try to clean it up as I have been going to a new gas station recently.

Does anyone suggest a new gas cap? mine looks fine.

I do drive quite a bit and have about 93k miles.

I used my bluetooth obd II and torque to check the pressure of the pump and it said it was running around 37 to 40psi which is the optimal range or at least at idle. I have to measure this while actually driving.

does anyone have any ideas it could be? I don't think its the pump, car drives fine. and yes its tuned.

could it be a sensor? carbon canister connected to the fuel line? module?

I do believe I had this once code once before but the dealer fixed it under warranty at the time.

I just want to get this fixed before inspection.

I know this issue could be anything really.

your help is appreciated.

yes i have done my HW and have checked prior threads.
 

·
Registered
Joined
·
1,096 Posts
Gas cap won't do anything. Fuel cleaner most likely won't either though it won't hurt. If you check out my long thread it's been stated this code simply means that the fuel module isn't getting the amount of fuel requested at a given time. You most likely won't have any drive-ability problems for months and months (I drove with it for half a year with no issues). Someone stated that their technician said when this happens on the V6 9-3ss it is almost definitely the fuel pump.
 

·
Registered
Joined
·
643 Posts
Discussion Starter · #3 ·
we will have to see.

I put the techron in and then put 12 gallons 93 octane on top of it.

I drove 20 miles and parked to drop something off.

went back to car and turned it on and there was no CEL.

I then proceeded to plug my bluetooth in and used torque to monitor the fuel pressure as I drove 30 miles home.

the pressure was operating optimally from what I could see. It was good at idle and at high rev. nothing lower than 250kpa and nothing higher than like 480 kpa.

Its been about 40 miles now and has not come back on.

Now like I said this CEL came back on like clock work. I'll let you know if it comes back on tomorrow.

if it comes on in a couple days, I'll try a little more techron.

however if it is the pump, how long do you think I got till I kill the pump?

I'd rather drive it till I know its the pump most definitely then I'll either get pricing for replacement or look to trade in.

However I think I'm in the clear. The Issues and symptoms point in my favor I think.
 

·
Registered
Joined
·
1,096 Posts
Can't say for sure how long the pump will last but like I said I drove for 6 months and never had an issue, occasionally throttle would be really sensitive like I would barely push the gas but it would work really hard. The CEL turns off and on during cycles, so thats normal that it will turn off every few fill ups
 

·
Registered
Joined
·
643 Posts
Discussion Starter · #5 ·
well i'll let you know if it comes back.

i have my fingers crossed.
 

·
Registered
Joined
·
1,470 Posts
I am going through it right now as well, I am pretty sure the cel will come back on, it all depends. Last night I parked my car facing downwards on a hill and that morning the cel went away, it came back on later that day though while I was driving. The dealer has already looked at my car and said that all the readings are normal, I bought it to another shop and the same thing, they both think it's the fuel pump that's on its way out. I have been driving it for about 2 months now, sometimes it drives fine and other time it feels like the car is working really hard. Also with the code came misfire on all 6 cylinders. I am preparing for that moment when I eventually will need to change the pump ::cry:
 

·
Registered
Joined
·
643 Posts
Discussion Starter · #7 ·
well its nearly 6 months later with 8,000 more miles and it came on again.

sometimes cars have ghosts and I am assuming this is one.

no driveability issues.

i was using regular gas for a while due to the shortage.

could that be a contributing factor.

either way as long as the car drives fine then I'm fine with it.

i'll probably try a small bottle of techron again or lucas.
 

·
Registered
Joined
·
5,873 Posts
well its nearly 6 months later with 8,000 more miles and it came on again.

sometimes cars have ghosts and I am assuming this is one.

no driveability issues.

i was using regular gas for a while due to the shortage.

could that be a contributing factor.

either way as long as the car drives fine then I'm fine with it.

i'll probably try a small bottle of techron again or lucas.
You might want to get a Tech II reading on it vs. a generic OBD scan. As you stated there is no FPR on the V6 as has a variable flow fuel pump.
It just might be that but if you're having no driveability issues and it only comes on every 6 months no big deal. I had the purge valve dealy thing come on every few months and drove over 40,000 mi. without replacing it.
 
1 - 8 of 8 Posts
Top