SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I had a problem with the blower motor on the HVAC at all, I replaced the blower motor resistor, now it runs on all fan speeds but will not stop running after the ignition is switched off. This is a manual climate control, I am not sure if there is a blower relay, I have not been able to find information on a location for it, I have been told there may be one.
Does anyone have any idea how to resolve the issue short of putting a manual toggle switch in line with the blower motor?
thanks in advance for any thoughts or solutions
Charles
 

·
Super Moderator
Joined
·
20,203 Posts
Sounds like you got a bad resistor.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Have replaced the resistor with 2 separate new units, blower runs in all speeds, but still runs when switch is off. Any other suggestions or ideas?

Thanks for any suggestions. Charles
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Where in the ignition is on, the blower is controllable from completely off through high speed, each speed works as it should. When the ignition is switched to the off position the blower motor it comes on and runs on low. The only way to stop the blower motor from running when the ignition is turned off is to pull the fuse out of the fuse box. I have not tried it with the Fob out of the ignition switch. I have replaced the blower resistor with two brand new units. I thought the first replacement might have been in bad. I don’t think they are going to replace this second unit again. Thanks in advance for any help with this issue.
 
1 - 6 of 6 Posts
Top