SaabCentral Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
HI, I've been having the hardest time in the world trying to find a solution for my problem maybe someone on here can help me out.

I own a 2004 SAAB 9-3 Aero. The head unit is the 2 inch monochrome square I think I've seen it referred to as an ES2 Unit. Anyways, everything works perfectly fine, except for the display, only sometimes. Every once in a while the display will turn all green, no black and nothing is visible. This does not last, it actually goes away after some time and slowly fades back to the proper colour.

Has anyone had this issue before? What could be wrong with the display?

As I said everything works fine and most of the time the display is fine as well. At first I thought it was the cold weather, I live Edmonton, Alberta, Canada. But I have started the car from cold before, has the screen work normal, and then somewhere along the way turn totally green. Any help is appreciated!
 

·
Super Moderator
Joined
·
20,049 Posts
Display could be going out or there is a bad connection to it. Gotta pull it and look.
 

·
Registered
Joined
·
531 Posts
Indeed. Find a used one on eBay and swap ICM the unit if you have a Tech2 (or access to one). I was just looking and they are under 100 bucks. There is a small thin ribbon cable which goes to the LCD. I'd check first that the connection isn't loose. Also, I think I may have my LCD sitting around collecting dust (I took apart my ICM to push it in the dash- see my android stereo post) but you'd need to verify the part number on top of the chassis.
 

·
Super Moderator
Joined
·
20,049 Posts
I think if you are just swapping ICMs and not EHUs and also not moving up or down (i.e. going from ICM2 to ICM3) you can just swap and it is plug and play. No?
 

·
Registered
Joined
·
531 Posts
I'd be nervous without a Tech2. It is the central brain of the bus systems (I-Bus 33kbps, P-Bus 500kbps, O-Bus 25Mbps)
 

·
Registered
Joined
·
5,459 Posts
I think if you are just swapping ICMs and not EHUs and also not moving up or down (i.e. going from ICM2 to ICM3) you can just swap and it is plug and play. No?
Not quite plug and play unfortunately, I just swapped an ICM3 in for an ICM2.
Radio functions work fine but I will need some Tech2 time as I have lost the following abilities among others:

Settings on rain sensing wipers
SPA not working at all
Speed sensitive volume settings (never really works but can't get to settings since change)
 

·
Super Moderator
Joined
·
20,049 Posts
Not quite plug and play unfortunately, I just swapped an ICM3 in for an ICM2.
Radio functions work fine but I will need some Tech2 time as I have lost the following abilities among others:

Settings on rain sensing wipers
SPA not working at all
Speed sensitive volume settings (never really works but can't get to settings since change)
Right, you went from 3 to 2. I think like for like you are fine.
 

·
Registered
Joined
·
58 Posts
Car's specifics are saved in ICM. To change them you need Tech2. Among these are:
Heated seats, SPA, rain sensor, climate settings, service data, Navigation/Phone capabilities, Voice control, AUX, etc.
You can safely swap units, but if you do not have access to tech2 it's best to look for one with similiar car equipment.

And as far as main topic goes: Screen or it's connection may be faulty. Take ICM out, open up front faceplate and check ribbon connectors.

It's possible to replace only front faceplate from other unit.
 
1 - 8 of 8 Posts
Top