SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
271 Posts
Discussion Starter #1
Hi, Everybody,
It's amazing: I haven't posted because nothing has gone wrong!
This radio is very nice except that reception is execrable. I wonder if the signal amp is bad or the radio is weak. Last week I passed my hand near the faceplate, and the radio lost reception, and this happens every pass of the hand.
Then, while reprogramming buttons, I pushed the scan button to bring up manual "M" tuning, and the engine stalled.
Thanks for any help.
Bill
 

·
Registered
Joined
·
8,418 Posts
Is your car a sedan or a wagon? Antenna system is different on the two.


The sedan seems to have a couple of possible systems. In any case, all the antennas use an amplifier. Also metallic window tint would do a number on radio reception.


If the car stalls every time you select manual tuning, you need an exorcist, or at least a new radio!
 

·
Registered
Joined
·
271 Posts
Discussion Starter #3
Hi, Ed,
Thanks for your reply.
It's a wagon. I suppose it's time for some old-fashioned troubleshooting. UGH.
Luckily it only stalled once.
 

·
Registered
Joined
·
8,418 Posts
The wagons have an antenna on each side glass of the cargo area, and it intelligently chooses which provides a better signal on FM.


There's quite a bit of information in WIS on the system, and how to troubleshoot it.


Reception in my wagon is perfectly fine. ;ol; Even the weather band (which your car probably does not have).
 

·
Registered
Joined
·
271 Posts
Discussion Starter #5
I'll have to look into the WIS files.
Oddly, I've had Peugeots and Renaults among other cars over the course of my lifetime, and I managed through necessity to gather quite a tool collection. Now, since I have these Saabs, despite their alleged quirkiness, my tools are getting rusty.
 
1 - 5 of 5 Posts
Top