SaabCentral Forums banner
1 - 20 of 21 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Hi I have a 2003 95 arc. I had a problem earlier with acc no blowing. I replaced maxi fuse and it started working-thank god! But I now have no radio, no power to sunroof, trunk will not release, and the door ajar ding is not sounding off. I did check fuse in side panel of drivers side dash and they are all good. Any ideas or suggestions will be of huge help and thank you in advance.
P.s.
My Sid panel does not work, I have replacement being shipped so if it is throwing a code I can not read it.
 

·
Registered
Joined
·
3,286 Posts
Classic TWICE module symptoms.

Remove the new fuse and see if the TWICE functions are restored. If so, then you'll know that there is a problem with the ACC (perhaps why the fuse blew in the first place).

If they are not restored, then you'll need to clear the TWICE of codes and reset.

Search the board for TWICE for more information.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
Thanks

I will do that now, my SID display came in today and it is showing me no codes, is that unusual?
But while I am thinking of it the acc face is giving me a 1 19 and a 2 22 could that also be the TWICE MODULE?
Thank you again for your help :)
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #5 ·
stupid stupid me.....

I took off the onstar antenna and put a fake shark fin over the spot where it onstar was. Could this possibly be a cause of my problems?
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #7 ·
Bus

The wire to the onstar roof antenna are both with. So not the bus, I am going to be pulling TWICE today and see what happens.....(fingers crossed) another stupid thought is that the owner manual shows another fuse and relay/fuse box inside the dash on the drivers side, is there really one there and would this be worth looking at?
From what I can see from code 19 is that I do have a ground problem which would give me a bad fuse, and 22 means system software reboot, but why would these pull the power to trunk, sunroof, and radio? (just talking this through....I hopes a light will go on......)
Also am I allowed to give a shout out to the company that sent me my replacement SID?
 

·
Registered
Joined
·
3,286 Posts
The wire to the onstar roof antenna are both with. So not the bus, I am going to be pulling TWICE today and see what happens.....(fingers crossed) another stupid thought is that the owner manual shows another fuse and relay/fuse box inside the dash on the drivers side, is there really one there and would this be worth looking at?
From what I can see from code 19 is that I do have a ground problem which would give me a bad fuse, and 22 means system software reboot, but why would these pull the power to trunk, sunroof, and radio? (just talking this through....I hopes a light will go on......)
Also am I allowed to give a shout out to the company that sent me my replacement SID?
The system programming controls the switches for the trunk, sunroof, etc. If the TWICE is messed up, none of that stuff will work. It's the brain for those things.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #10 ·
Beating a dead horse.......

Ok so before I went and took up my seat and removed twice I did more research......eggsngrits your right it is something to do with this I 100% agree with you.
My question is this , from what I can see on this site is that if this is the issue and I take it off and work on ithe twice more than likely my car will not restart when i reenstall until I get reprogrammed with a tech II, is this true?
 
G

·
disconnect the twice and turn the ignition on. its only when you switch the twice for anther thats when it needs to be programmed.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #12 ·
Beating the horse for a second time.......;)

Thanks blackls1ttop,
Heres another question for y'all

I will consider myself very lucky. My dad is an old GM employee and has a friend with a garge that is willing to let me use his tech II DEVICE. Should I just let the tech II make the diagnosis and see if it will recalibrate before I remove twice module?
 
G

·
yes! have the tech II check the TWICE unit. that wounld be the best way. but he has to have the SAAB software installed in the TECH II. if that does not work getting to the TWICE is just 4 torx bolts, and put the seat on the back seats and thats it.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #14 ·
Conclusion.....

I figured I would tell everyone how this ended....the tech II did recognize a ground or open Circuit. The twice module checked out good. Decided to go through driver side fuse panel again with voltage meter and sure enough fuses 8, 9, 10, 21, and 25 (if I remember correctly-might have been 26) had no power what so ever. And when I was able to see in and behind it became very evident of what happened.....a #@$£ mouse had nested and destroyed some of the connections. So another hour and half of work and I have trunk, door locks, sunroof, radio, and the replacement SID is bright and working properly. (anyone in need of an SID for a 95 check out kramers Sid repair on eBay 149.00 or will fix your old one).
So blackls1ttop, eggsngrits, and lep3 thank you for all your help and thanks to the creator of this site, HUGE help.
 
G

·
^^^ glad you figured out the issue, i too have a 03 arc and had some huge electrical issue that just got resolved. i had many issues with fuse 26 blue/red wire, that goes to most of the components in the car including the twice.
 

·
Registered
Joined
·
5,709 Posts
(anyone in need of an SID for a 95 check out kramers Sid repair on eBay 149.00 or will fix your old one).
Glad everything worked out but before you recommend someone you should do a search on the forum. Kramer has shafted allot of people including myself with sub-standard work.:evil:
 

·
Registered
Joined
·
8,299 Posts
I figured I would tell everyone how this ended....the tech II did recognize a ground or open Circuit. The twice module checked out good. Decided to go through driver side fuse panel again with voltage meter and sure enough fuses 8, 9, 10, 21, and 25 (if I remember correctly-might have been 26) had no power what so ever. And when I was able to see in and behind it became very evident of what happened.....a #@$£ mouse had nested and destroyed some of the connections. So another hour and half of work and I have trunk, door locks, sunroof, radio, and the replacement SID is bright and working properly. (anyone in need of an SID for a 95 check out kramers Sid repair on eBay 149.00 or will fix your old one).
So blackls1ttop, eggsngrits, and lep3 thank you for all your help and thanks to the creator of this site, HUGE help.
THe SID will fail, search Kramer on here ( or just google kramer scammer saab) He uses the 2 sided foam tape fix that you could ahve read about and done for 99 cents. they last a few weeks ( jst long enough to get a good review on eaby.

BBA-reman is a reputable multi-million dollar global company that fixes em for less and guarantees them for life...
 

·
Registered
Joined
·
13 Posts
Sid??

THe SID will fail, search Kramer on here ( or just google kramer scammer saab) He uses the 2 sided foam tape fix that you could ahve read about and done for 99 cents. they last a few weeks ( jst long enough to get a good review on eaby.

BBA-reman is a reputable multi-million dollar global company that fixes em for less and guarantees them for life...
What was wrong with your SID in the first place?
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #19 ·
Sid

Sorry I could not get to a computer until this am.......
The pixels were broken on mine. When I bought this car 3 years ago it was the only thing not working, so I did check out the cost of replacing (400-600) and I also did check this site at that time. The only thread I found at that time was a DIY to repair it myself, which I did try and it did not work, so when I saw this one by Kramer (which everyone here seems to dislike) for 149.00 I jumped on it. I recieved it within 3 days and he does offer a lifetime warranty, I plugged it in and it works great. I did have questions for him, and he gave me a second email and phone number. Right now I have no problems. It if there are any I will post them, but at this moment I am happy and will enjoy my DTE, TEMP, TIME radio stations.......all those little things I have missing for years.
 

·
Registered
Joined
·
3,286 Posts
madi139 said:
#@$£ mouse had nested and destroyed some of the connections. So another hour and half of work and I have trunk, door locks, sunroof, radio, and the replacement SID is bright and working properly.
So blackls1ttop, eggsngrits, and lep3 thank you for all your help and thanks to the creator of this site, HUGE help.
WOW! That's a new one on me. Glad to hear that your TWICE was good and it was just 'disconnected' if you will. Much, much less expensive.;ol;
 
1 - 20 of 21 Posts
Top