SaabCentral Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
248 Posts
Discussion Starter #1
i'm getting *very* (less than 24 hours, possibly) close to closing a deal on a 2003 9-3 arc... i was just wondering if there's anything specific i should look out for in the last test drive i plan to take before actually buying the car? it's going to be my first used car purchase (and first car) so I don't have a really large idea of what to watch out for other than glaringly obvious problems (of which i could find none). are there any known issues that i should look out for? any miniscule signs i can try to pick up on that could signal larger issues?

any help is appreciated :) the closer i get to actually forking over the money on this car, the more nervous i'm getting.

if it helps, here's the vehicle in question: http://usedcars.com/Sites/UCC/vehicledetail.aspx?make=Saab&model=9-3&zip=12205&vehicleId=7178243

once again, anything at all that you can tell me is greatly appreciated!
 

·
Registered
Joined
·
85 Posts
Being a 2003 ARC owner, myself.. I'd say check all records. Make sure proper maintainence has been done and recalls have been taken care of.

Also... this might have been a problem in jusy my ARC, but make sure the motor mounts are in good shape. I bought my ARC 2 months ago with 25k miles on it and within the first 1,000 miles of driving it, my right side tranny and engine mounts gave.. which struck me as surprizing but it was fixed by the dealer...so i'd get that checked...and since the manufacturer warranty on the car ended almost 3 months ago, i'd also inquire about any other warranties your seller may offer.

Other than that, it's all about how much YOU want it.
 

·
Registered
Joined
·
108 Posts
i've got an 03 arc and I would definetly get the VIN call up a saab dealer near you and find out what kind of warranty work was done to the car. I didn't do so until after owning my car to find out there was almost 3 pages full of reported warranty work from the dealer. So far my drivers and passenger side window lift kit/regulator have broken and i have a ghost electrical issue that causes my SID to report a non-working brake light and turning signal light. The previous owner also had it taken into the dealer to have it fixed but they could not find anything. Now that my warranty is up, i'm just crossing my fingers that it's just a loose bulb or something. But other than that my 03 has been good!
 

·
Registered
Joined
·
1,567 Posts
i couldn't be any happier with my purchase.. i'm nearing one full year of ownership, $2500 in mods and not a single hitch. *knock on wood*

also it's got nearly 50k miles so you have to imagine most kinks are worked out.

my only opinion.. talk him down some. that's a bit less then what i paid but my car only had 20k miles. good luck!
 

·
Registered
Joined
·
12,509 Posts
There were only three "Recalls" on 03, but a bunch of "Service Campaigns" ie The AutoTrans coolant O Ring replacement, Steering Column/lock issue, Key Fob replacement, Gas Cap replacement etc. Be sure to see what Service Campaigns and TSB's (Technical Service Bulletins) were met.

The Three recalls were a Seat Belt retractor, brake vacuum valve and a cooling system issue. They can be found on the NHTSB website if you'd like to read more.
 

·
Registered
Joined
·
12,509 Posts
fishhyren11 said:
I would recommend checking out the NHTSB website (specifically the "search complaints" section http://www-odi.nhtsa.dot.gov/complaints/).

Also, take a look at this as well: http://www.truedelta.com/results0907.php

Not saying don't get it- but just be sure you know what you might be getting into.
Yikes, how not fair with that first link, most are individual complaints and were resolved under warranty.....a couple of the issues where I read the summary already had TSB's and Service campaigns existing. And one Dope said his parking brake failed and the car rolled down a hill.....what, he parks in Nuetral? Forgot to pull the brake up eh? Look at any car on that site and there;s an equal amount of issues.

It's getting like everyone who never owned an 03 loves to Bash them...
 

·
Registered
Joined
·
248 Posts
Discussion Starter #8
wtfwill said:
my only opinion.. talk him down some. that's a bit less then what i paid but my car only had 20k miles. good luck!
ah, forgot to mention we're paying $13.5 for it, not the $15 :D
 

·
Registered
Joined
·
160 Posts
JonV said:
Yikes, how not fair with that first link, most are individual complaints and were resolved under warranty.....a couple of the issues where I read the summary already had TSB's and Service campaigns existing. And one Dope said his parking brake failed and the car rolled down a hill.....what, he parks in Nuetral? Forgot to pull the brake up eh? Look at any car on that site and there;s an equal amount of issues.

It's getting like everyone who never owned an 03 loves to Bash them...
Again, I'm not bashing, just saying it's a valid place to look at concerns- many have been resolved, but you can compare to other years at the same time...

I submitted a complaint on my 06 that the shift nob flew off while shifting in traffic... All cars are going to have their issues, some more than others...
 

·
Registered
Joined
·
297 Posts
krock1030 said:
Being a 2003 ARC owner, myself.. I'd say check all records. Make sure proper maintainence has been done and recalls have been taken care of.

Also... this might have been a problem in jusy my ARC, but make sure the motor mounts are in good shape. I bought my ARC 2 months ago with 25k miles on it and within the first 1,000 miles of driving it, my right side tranny and engine mounts gave.. which struck me as surprizing but it was fixed by the dealer...so i'd get that checked...and since the manufacturer warranty on the car ended almost 3 months ago, i'd also inquire about any other warranties your seller may offer.

Other than that, it's all about how much YOU want it.
How did you know the mounts were bad, or went bad? Were there any symptoms? I've often got a vibration through the car that comes from the dirveline, and I can't find out why. Is this what happened to you?
 

·
Registered
Joined
·
85 Posts
KrOlDoG8 said:
How did you know the mounts were bad, or went bad? Were there any symptoms? I've often got a vibration through the car that comes from the dirveline, and I can't find out why. Is this what happened to you?
I knew because my car started to feel like it was lagging. And every now and then- going from 2nd to 3rd or 3rd to 4th, it felt as if my tranny would slip and like my engine was over-exerting itself... This could also be because I had bad engine AND tranny mounts.

I would get it checked as soon as possible if I was you, just to be safe. You motor mounts could be worn... I'm glad I got mine fixed because the technician showed me my old motor and tranny mount and the rubber casing inside of both were completely gone!
 

·
Registered
Joined
·
1,204 Posts
I've just looked at the pics and you're getting the colour I should have gone with ! What I did notice was that you have a model with the fading door handles... this was covered under warranty... try a search ! I bet you could easily haggle a new set of door handles to clinch the sale :cheesy: Another point of attention should be drawn to the mirror base surrounds... if they are chipped or corroded in any way then haggle for those as well...they are another item that the 03's got changed under warranty. Other than that take heed of the previous posts but if the service book is all stamped up and you like the ride then 'Caveat emptor'

Look at the colour of the door handles of the 93 at the side of yours... see the difference... yours should be like that...

 

·
Registered
Joined
·
248 Posts
Discussion Starter #14 (Edited)
haha yep! the doorhandles... the first salesperson we talked with (who no longer works there) actually told us "they are supposed to be like that." you should've seen the stares me and my dad exchanged when she said that... however the dealer replaced them for us with brand new ones :D so they are the nice black ones and shouldn't be prone to that wear problem. :)

picked up the car today btw... i'm in love :p:p
 

·
Registered
Joined
·
248 Posts
Discussion Starter #20
thanks everybody, so far it's been amazing. :) really hard to get used to the power of the car... both my parents have SUV's and so that's pretty much all i've ever driven. as you can imagine it's a bit of a different feel :p
 
1 - 20 of 20 Posts
Top