SaabCentral Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
I replaced my TWICE, locks, ignition cylinder, key sensor, key antenna module, and keys. I did not replace the ECU.

I put the key in the ignition... at first the SID said key not recognized. Then after pulling it out and putting it in the message disappeared and I had no errors. When I put the key to the ON position I hear the fuel pump prime, and when I turn it further it cranks strong but will not start. Makes me think there is no spark.

Why aren't I getting key not recognized any more?

Would the alarm system pull spark and still allow crank and fuel?
 

·
Registered
Joined
·
867 Posts
I replaced my TWICE, locks, ignition cylinder, key sensor, key antenna module, and keys. I did not replace the ECU.

I put the key in the ignition... at first the SID said key not recognized. Then after pulling it out and putting it in the message disappeared and I had no errors. When I put the key to the ON position I hear the fuel pump prime, and when I turn it further it cranks strong but will not start. Makes me think there is no spark.

Why aren't I getting key not recognized any more?

Would the alarm system pull spark and still allow crank and fuel?
Did you get the TWICE and Key married to your car with Tech II?
if not, there your issue.
If you did get it married were you told why you got the key not recognized message?
ECU does not need to be replaced but it does need to be married.
 

·
Registered
Joined
·
3,951 Posts
You should be able to start the car with the replacement key and fob before you use the Tech II; like I said in your other thread. Did you try that? And what happened when you did? And if you did have it programmed with a Tech II it needs to done again.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
There has been no programming or marrying. I do not get a key not recognized message to bypass.

The car just cranks away, fuel is there, no spark.

Twice it has started, ran nice for 4 seconds and died.
 

·
Registered
Joined
·
869 Posts
There has been no programming or marrying. I do not get a key not recognized message to bypass.

The car just cranks away, fuel is there, no spark.

Twice it has started, ran nice for 4 seconds and died.
Has the CPS ever been replaced? These symptoms immediately make me think the CPS....
 
1 - 8 of 8 Posts
Top