SaabCentral Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
A colleague has a 2002 9-5(9600) Saab sedan. It has been having continuous engine problems, eventually he ordered a good used engine from UK, which the mechanic successfully finished installing today.

Apparently the engine cranks but can not start. When ignition ON the main instrument displays following signals;

1) Flickering Engine Management Light
2) Park indicator light flashing
3) Third (3rd) gear indicator light flashing
4) Turbo needle moving up/down
5) Bit of sound behind main instrument panel

All these signals mentioned started after replacing the engine, see attached instrument video

I have a TechII which I use on my 9-3 Saab hence request from my colleague to assist troubleshoot.

If anyone has a solution or hint please kindly help.
 

·
Registered
Joined
·
3,907 Posts
Check all ground connections are secure and clean.

What is the condition of the battery?
.
 

·
Registered
Joined
·
2,441 Posts
Everything that needs to be electronically "married" to the car has been done as well? It sounds to me like an electronic communication issue.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Everything that needs to be electronically "married" to the car has been done as well? It sounds to me like an electronic communication issue.
Nope, nothing electronically done. Took a mechanical view being only engine replacement hence it will be just "plug and play" thing. Kindly enlighten me what needs to be "married"
 

·
Registered
Joined
·
2,441 Posts
Nope, nothing electronically done. Took a mechanical view being only engine replacement hence it will be just "plug and play" thing. Kindly enlighten me what needs to be "married"
Are you using your original ECU, or the ECU that came with the engine? Could be as simple as Mimmi said though.
 
1 - 11 of 11 Posts
Top