SaabCentral Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi

This is my first time posting. Usually find the solution before it comes to this. So about a week ago my car started dying over night due to a parasitic battery drain. After a few days of jumping it, I was told to take the negative off of the battery to stop the drain. So I popped my hood and disconnected the negative. I did this while the car was running, immediately after my car started to run a little rough soni turned it off. Since then it just cranks but doesn't turn over. I've sprayed started fluid into the intake and fires for a second but dies right away. I've tried to unhook battery to reset my car but no luck. Anyone know what's going on here? Thinking some type of security issue but haven't found anything yet. Please help!!
 

·
Registered
SAABless booo
Joined
·
2,520 Posts
It could be as simple as your battery is no longer sustaining a charge powerful enough to start the car. Could be the Alternator as well. You should be able to run the car from the Alternator alone with no battery once it's started with no ill effects. Have you checked or had a shop check what the actual load voltage is on the battery?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Yep I've ruled out the battery and the alternator. Both were replaced a few months ago. Another thing that I forgot to mention is the ignition. the rubber part that goes around it came off and exposed the little coil pack under there, one if the ends fell off the connector so I have to hold the wire there to start car. SID displays shows something about security system. Has the 2 years I've owned the car do don't think that's the issue. Will sometimes say key not accepted if not holding the wire just right when starting.
 
1 - 3 of 3 Posts
Top