SaabCentral Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I've got an 08 93 sc aero, that up until today had literally zero issues. Was driving through town, and managed to hit a bump that jarred the car pretty good. Not long after, the engine light came on. It's nowhere near time for a service, had no warnings, and it seems to be running great still. Temps are fine still also. I can't afford to take it to the local specialist since ER bills are ridiculous without insurance. Are there any suggestions to where to begin looking for an issue? It's an auto with a stage 1 BCB tune (I think that's right) if that matters.

Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
11 Posts
Discussion Starter #2
To add to that, I pulled the engine cover and checked all the electrical connectors and drove it. With traction control off and the trans in sport mode it still runs like it has been, but the fans didnt kick in when I shut it off. It usually comes on in weather like this so I'm stumped.

Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
2,939 Posts
Take it to any parts store, let them scan it for codes, record the exact codes and then let them erase the codes, and then post the codes here if the check engine light comes back
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Looks like I'll have to wait to try that. The light didn't come on today, so I'll update once it comes back on and I get the codes.

Sent from my SM-G965U using Tapatalk
 
1 - 8 of 8 Posts
Top