SaabCentral Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Hello everyone,
Hope you can help me, Ive been searching everywhere but can't find right answer, so I'm really asking for your help as I love this car and would love to drive it back asap!
So here's my problem with my 1999 9-5. Car cranks well, but doesn't fire. It started happening last week. When I stopped at the grocerie for a couple of minutes, car wouldn't fire up randomly for 10-15 min (cranks but doesn't fire) and then start normally. Red light on dash (engaged alarm system) was blinking and making noize sometimes WHILE driving (this is why I mostly suspected the alarm system)
However, it's been 2 days that the car doesn't start anymore!!!
It's not the battery, car keeps cranking normally without loosing power (starts loosing power after the xth try), nor the cps (previous owner changed it). I'm suspecting the TWICE module unit (read about it on other discussions but can't find right information) or something like that. SID displayed SERVICE THEFT ALARM, so I changed the battery inside the key fog. Tried to reprogram the key as told in owner manual, but doesn't seem to work. Also, alarm was going randomly off during night (I stopped locking the doors to prevent it), took off the alarm system last week and changed batteries CR17335 (however previous batteries still held a charge of 3.05V, but I changed them as I got inside anyway).
So after changing batteries inside my key and inside the backup anti theft alarm system (front driver side wheel location), car still doesn't start!!! The red light in the middle of the board still blinks and makes noize when I attempt to fire the car. Car can crank for 30min straight and not fire up. On a couple of occasions, car would start but would die off 3-4 seconds after firing up (even more suspecting an alarm system cutting off the fuel or whatever)
Is it the TWICE modul unit? Immobilizer? What can I do without spending a lot of money $$$?
Please I really need help from you!
Thank you for your time and help, Dave
 

·
Registered
Joined
·
1,887 Posts
does your key fob still lock/unlock the car?

When you turn your key in the ignition, does the sid say "key not recognized"?

After replacing the battery in the alarm siren, do you still get a "service theft alarm" notice?

If your fob still works to lock/unlock the car. When you have your key turned to the on position, hit the unlock button on your fob a few times. then try to crank the car.


Otherwise, have you tested to see if you are getting fuel?
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top