SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey so I have a 1997 Saab 900s 2.3 non turbo automatic, bought it for a $1000 as a commuter car and I love it. Although the other day driving home from work I was about a quarter mile from my house at a stoplight and I accelerated and then suddenly it died with no warning. coasted it home and parked it. Tried starting it, I hear a click that sounds like the starter trying to engage but the engine does not turn over. When I turn on the key the dash lights up and everything works. I then let the car sit for about a week and then i went to show a friend what happens when I turn the key and this time no lights or anything came on. Grabbed my meter and took a reading off the battery and it was completely dead, this is very strange to me as the battery I had just bought from les schwab two days before it stopped running. I also checked the battery the day it stopped running and it had 12.8 volts. I really am stumped here as to what is wrong any help will be greatly appreciated!
 

·
Registered
Joined
·
18,094 Posts
If you bought that battery because the previous one died, it's possible that you have a "drain" on the battery that's killing it. You might want to hook up an ammeter in series with the positive battery cable and see how much draw there is when the car is off.

I would think the first step would be to get a battery charger and charge it up. See if it takes a charge. If so, we can give you some diagnostics to follow.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
I bought a new battery as the old one load tested bad. I took a known good battery from my pickup hooked it up and still the same problem. When I try and start the car all I get is a click. Pulled the starter off for ****s and giggles and Bench tested it and seems to work fine.
 

·
Registered
Joined
·
12,352 Posts
You might try removing the plugs and see if you can turn the engine over by hand with a socket wrench on the crankshaft pulley bolt. With the plugs out, it should turn fairly easily unless something is binding in the engine or transmission... Ron
 

·
Registered
Joined
·
9,155 Posts
I bought a new battery as the old one load tested bad. I took a known good battery from my pickup hooked it up and still the same problem. When I try and start the car all I get is a click. Pulled the starter off for ****s and giggles and Bench tested it and seems to work fine.
When it makes the click as you move the key to 'start', do the headlights and dash lights stay on?

Is there continuity between the starter terminal and the battery terminal of the cable?

I assume that by "bench tested fine" it spun and the copper cable from the solenoid to the starter body is intact.
 
1 - 7 of 7 Posts
Top