SaabCentral Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
This vehicle has been a good driver since April when it was put on the road. Recently, the check engine light came on and flashed for a bit, as suddenly anything over slight pressure on the pedal would cause the engine to seemingly misfire, resulting in a complete loss of power.

It sounds fine at an idle, I am hoping nothing too internal is damaged.

The local people I go to may not have the right software on their scan tools, and my check engine light doesn't flash, something I read about the T-5 software.

I was wondering if anyone had a lead.
 

·
Registered
Joined
·
130 Posts
Power loss

Could be the ignition pack on top of the engine.
Four torque screws to remove, plus a wiring plug on the right hand side.
Look for green oil leaking, or a crack or both. Keep pack upright for a while before replacing if nothing found.
Worth buying/borrowing a replacement ( expensive ! ) just to try. They don't last forever.
Bill
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
I tested it with a known working DIC, and tested the DIC that was in it. Didn't seem to be an issue.

Purchased a scan tool. Two error codes: P1416 Fuel system/misfire detected - fuel level low
P0302 cylinder 2 misfire detected
Since then I have replaced the fuel filter and put in 7 more litres. Same issue no changes
 

·
Registered
Joined
·
21 Posts
Discussion Starter #5
put another plug in replacement, misfire gone. existing plug was a 3 spark. once removed had a blue discolouring. I am guessing manufacturer defect.
 
1 - 5 of 5 Posts
Top