SaabCentral Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi All

Im a little stumped at the moment, and was wondering if anyone had any suggestions.

Issue: ~Full beam (intermittently )will not cancel first time with the indicator stalk, so you have to keep trying until it cancels which just ends up flashing everyone!! it doest happen all the time, then just catches you out!!

I have tried the following:
New(salvaged)column stalk, no difference, so exchanged for the large red headlamp relay, which was taken from a known working full/dip beam car, This actually made things worse and took probably 10 pulls of the stalk to activate full beam.

What else can i try/check or what am i missing?? Thanks in advance.
 

·
Registered
Joined
·
3,461 Posts
Try checking the main light relay in the engine bay. Often the joints get old cracked. A resolder, for $25.00 approx, and you are good to go.

Been there done that
 

·
Registered
Joined
·
2,026 Posts
In my experience it is usually the orange Lamp Check Relay that causes problems (rather than the red high/low beam relay).

271557
 

·
Registered
Joined
·
3,461 Posts
I have checked. Resoldered mine, and a colleagues.
 

·
Registered
Joined
·
696 Posts
It's usually the big relay up front. Mine works when it wants to. If I give it a smack sometimes it'll work fine for a week and then act like you've seen again.
 

·
Registered
Joined
·
8,814 Posts
Check connectors below relays.
 
1 - 6 of 6 Posts
Top