SaabCentral Forums banner

1991 SAAB 900i 16V ABS not cooperating

228 Views 7 Replies 3 Participants Last post by  wdssaab
After driving over some road joints the ABS light went on. ABS does not work any longer, the rest of the system still does (i.e. no hard pedal). I tried to read trouble codes from the ECU several times, following the procedure as defined, but only got a code once (1222 I think), otherwise nothing but the yellow light constant on. Checked the main valve block and the internal resistance seems out of spec, appr. 9 Ohms. Before I buy a new main valve block I would like to verify that I actually read the code right. What is the trick to get the ECU to flash trouble codes?
1 - 8 of 8 Posts

· Registered
Joined
·
13,181 Posts
See here:


If you did get 1222, that means the main valve has a fault.
 

· Registered
1991 SAAB 900i 16V 3-door
Joined
·
8 Posts
Discussion Starter · #3 ·
Yes, and I realise that I actually checked the wrong valve (the valve block with the 7-pin connector). Will check the correct valve tomorrow. I am am not sure though that I got that trouble code right since it only was flashed once and I messed up the procedure. Still - with the correct procedure no trouble codes are flashed, and the light is on. Can I erase the trouble codes by disconnecting the ECU overnight?
 

· Registered
1991 SAAB 900i 16V 3-door
Joined
·
8 Posts
Discussion Starter · #4 ·
UPDATE:
Checked the main valve - resistance and wiring harness OK --> I probably misread the code

Checked the diods - OK

Disconnected the ECU overnight, will check willingness to cooperate tomorrow

Wheel speed sensors resistance is OK, will check trigger rings tomorrow
 
1 - 8 of 8 Posts
Top