SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi I have a Saab 900 turbo , circa* 1988.. The car will crank and run but will not run above about 1200 rpms . I can put the car in drive but the engine stays in the 1000 or so rpm range. Any help as to were to start or what might be the problem would greatly be appretiated.
Thanks
Jason
 

·
Registered
Joined
·
780 Posts
Hi I have a Saab 900 turbo , circa* 1988.. The car will crank and run but will not run above about 1200 rpms . I can put the car in drive but the engine stays in the 1000 or so rpm range. Any help as to were to start or what might be the problem would greatly be appretiated.
Thanks
Jason
Check the Hall sensor connections, clean them up and reconnect, carefully inspect the connector.

Then check the connector connections to the ICM and if is working properly.

The Hallsensor is a little plug on the distributor with 3 cables on it, with time it can crack and give all sorts of problems.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
I am going to go over the basics such as fuel pressure and connections in the morning . I am open as to what may be or has possibly been in the past problems that occurred with these automobiles . I figured no better place than here to ask .. Just want to get off on the right foot . I appreciate any knowlege given..
thanks..
Jason
 

·
Registered
Joined
·
40 Posts
Thanks I will try this.. I appretiate the input I will let you know how this goes.
Jason
Have you figured anything out on the problem? I have an 88' 900 Turbo vert and I ran into a problem last night with my car not wanting to go when i gave it gas. It would rev to 1200-2000 before shutting off. I noticed my distributor had some wires hanging out and looked cut. that was my problem, maybe you can check that out on yours!
 
1 - 7 of 7 Posts
Top