SaabCentral Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
now for an 85 900t with a 16 valve thats having a cold start problem what should be done? i have a second unit but its ( last numbers) 505 instead of a 502 would this work if i throw her in?
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #3 ·
no the accual cold start unit right next to the distributer. it is a bosch it has a circled number (011) and the large number is 0 280 140 505
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #5 ·
really? so what is the 502 or (o11) with air tubes to it? all i know is it keeps my car running at about 2000 rps when i have the air tubes to it plugged in..
 

·
Registered
Joined
·
4,388 Posts
Two hoses and one electric connector? That would be the Idle Air control valve, it only controls idle. Try cleanig the valve with light oil like wd-40.
 

·
Registered
Joined
·
4,388 Posts
So, how about that cold-start issue? How does the car behave when you start it cold? Crank, start,run,die over and over untill warm? then I would point you back to the A.M.M..
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #12 ·
once you start it you have to tap the gas for about 35 to 45 seconds then its fine in fact it only died once and before this it wasnt running for two years.
 

·
Registered
Joined
·
4,388 Posts
clean and oil that a.i.c. valve, run the engine, note it's behavior,shut it off and try again tomorow(cold). If you now have a steady idle 875+/- 50 rpm you are close. Then diconnect the Air mass Meter ,note any change and plug the connector back in. If the idle improves with the A.m.m. plugged in then the A.M.M. is probably good......................................................................
 
1 - 13 of 13 Posts
Top