SaabCentral Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
247 Posts
Discussion Starter · #1 ·
hey Saabers whats up? well anyways just a quick question is it normal for my car to be pushing around 11 psi when i floor it i got an lpt 9-5 and just wondering if thats ok or if i just got an inacurrate gauge.
 

·
Registered
Joined
·
1,621 Posts
hey Saabers whats up? well anyways just a quick question is it normal for my car to be pushing around 11 psi when i floor it i got an lpt 9-5 and just wondering if thats ok or if i just got an inacurrate gauge.
that sounds a little high for an lpt model. i thought that in 3rd max boost was 8-9psi for the lpt, but i could be wrong.

wait for someone else to chime in as well.
 

·
Registered
Joined
·
1,621 Posts
well is it to high for 1st gear? i havent checked the other gears but in 1st gear i was reading about 11
damn yeah dude thats really high for first. on my aero I think i top out at 8 in first.

you might be over boosting as a result of a faulty wastegate. it might need adjustment.

(maybe there arent boost limiters on the LPT? im not sure about this. check and see if you have 11 psi in ALL gears first)
 

·
Registered
Joined
·
463 Posts
lpts aren't limited in 1st and 2nd. official figure for lpt from saab is 0.4bar for the lpt which is around 6-7 psi, most of them run higher than this though. saabs don't run a set boost though, its a set amount of airflow, so, say if you have heatsoak in your intercooler your car will run higher boost so yo are still making the same power. essentially with saabs the boost varies depending on conditions because the clever computer wants you always to have the same power.
 

·
Registered
Joined
·
22,211 Posts

·
Registered
Joined
·
5,000 Posts
I'd guess (note: guessing!) the limit is there but they never make enough torque to reach the limit.

Someone with T7Suite could look at the LPT map and tell us I suppose.
 

·
Registered
Joined
·
1,621 Posts
right but it is winter time right now so i'd imagine its still fairly cold in RI. so supposing you still had some form of heatsoak, would the car really be boosting 4 psi over the "stock spec"?

i did get a feeling that they werent torque limited in the first gears though.
 

·
Registered
Joined
·
1,621 Posts
sunpro is kind of a cheapo gauge, but i dont know why it would be inaccurate. did this just start happening or did you have 11psi since you bought it?
 

·
Registered
Joined
·
1,621 Posts
yeah ok than it could possibly be an incorrect calibration. only one way to know for sure with that though, you'd need to buy another gauge.

start with the cheapest if youre concerned about it, then move to the wastegate. check the hoses coming off the BCV and make sure they're intact.

If it were me, i would check my tubing for kinks and anything first, then try another gauge, and lastly start looking into wastegate issues. usually though when its the wastegate, you will be REALLY REALLY overboosting, as in 25+ psi if you had REAL issues with it.

In all honesty, youre probably fine as is, although 11psi is higher than the LPT is supposed to go generally.
 

·
Registered
Joined
·
247 Posts
Discussion Starter · #15 ·
yeah ok than it could possibly be an incorrect calibration. only one way to know for sure with that though, you'd need to buy another gauge.

start with the cheapest if youre concerned about it, then move to the wastegate. check the hoses coming off the BCV and make sure they're intact.

If it were me, i would check my tubing for kinks and anything first, then try another gauge, and lastly start looking into wastegate issues. usually though when its the wastegate, you will be REALLY REALLY overboosting, as in 25+ psi if you had REAL issues with it.

In all honesty, youre probably fine as is, although 11psi is higher than the LPT is supposed to go generally.



yea im defintly going to check everything out. I just want my car to be running normal before i do an ecu tune.
 
1 - 15 of 15 Posts
Top