SaabCentral Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys,
I noticed recently that the radiator fans are not turning on my 08 2.0T combi. I'm not over heating, but with the weather getting warmer it is slightly concerning. Lol. No codes are being thrown. I was looking at the manual and I don't see a fuse for the radiator fan. Is it inline with the fans possibly? Relay? Resistor? This one is really throwing me for a loop. Any help would be greatly appreciated.
Thanks!
 

·
Registered
Joined
·
5,473 Posts
Might be the fan control relay unit PN 24418357 as they do fail on occasion.

Mounted above fans to radiator support.

 

·
Registered
Joined
·
5,473 Posts
There are two fuses in main under hood fuse box #35 and #36 that feed that controller with power, one for each fan. There is a temperature sensor screwed into engine head (front side between ECU and air cleaner). This is used for fan control as well.
 

·
Super Moderator
Joined
·
9,855 Posts
May be a silly question, but have you thought about the possibility the fans aren't kicking in because it's not hot enough yet?
 

·
Registered
Joined
·
48 Posts
Get a scan tool and look at coolant temp (ECT). The specific thresholds are probably published in the service manual, but the low speed will probably come on around 98C and the high speed around 105C. If you are below the low threshold the fans should not be on. Some vehicles will turn the low speed on regardless of temp if the a/c compressor is on.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
I have. Lol. I drive about 15 miles to work every day. Nearly all highway. I have been trying the last week to get it to kick on. I have been blasting the ac the whole way everyday and I check to see if it is working every day and nothing. That and I remember last spring it was running all the time. Also it isn't running after I shut the car off either.
Is the temperature sensor your referring to the coolant temp sensor? The one that controls the temp gauge? Because the gauge has been working as far as I know. And wouldn't that throw a code?
 

·
Registered
Joined
·
734 Posts
Sorry, but no this is the forum I wanted.
Checking for someone's 9-3 2005.

Trying to figure something out:
Car overheats, radiator is cool, and aux fans don't turn on.
Is this a bad thermostat? Or a bad aux fan? Or both.
Unsure of how the cooling system on these cars work.

Do the aux fans sense engine block temp or radiator temp?
If the radiator is cool, and engine overheating, it should be the thermostat I would think.
Trying to diagnose.
 
1 - 11 of 11 Posts
Top