SaabCentral Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
It started with my roof giving me a chime whilst driving down the motorway saying close roof, followed by roof obstructed, please try again. I had some water leaking in from right passenger headrest area and I first thought (and it may still be) that it had cause a sensor to break. However I have other problems occur at the same time. The rear window defrost won't work, and this has cause my heater / ac controls to stop working. Instead of showing 20c they now just show 1-10. I now am unsure if the roof/back window are causing a short that is affecting the climate controls. I have dried and repaired the effected area on the roof and hoped it drying out would solve the problem. The car sat for 12hrs and in the morning I was pleased to see it started to work again, but quickly deteriorated and went back to making the chiming noise and the climate controls went mental. Going from 20c to 1-10 again. The roof then stopped working.
This clearly is some sort of electrical problem somewhere but I cannot begin to narrow down what systems could be linked, I assume probably the back window heater is doing something to both the climate controls and roof but I have little electrical know to know where or how to begin testing the problem.. Any help to guidance gratefully accepted
 

·
Registered
Joined
·
8,808 Posts
Check rear defroster wire thoroughly (use gloves and run hand whole wire). If there is cracks or burn marks, fix it ASAP.
Wires goes thru left hinges of roof and if fittings are loose, wires get stuck and cracks.
If this will not help, you need TECH2 to check all roof sensors. 6th bow locking sensor fault will cause this chime and text. There is 2 locking sensors, 1/hinge.

Water leaks: check reserve tire compartment for water.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
Thanks. I did some checking around I think some of your ideas may have helped. I'm not sure if I just had a day of the perfect storm and I'm looking for a single problem when there isn't one.
I looked in the rear passenger side and low and behold the heater wire was stuck between the two parts of the roof mechanism. It was not damaged badly so I removed it and the roof did go down and back up.
I thought maybe that things were solved. I am hesitant to put the roof down again incase I can't get it back up. It rains alot in the UK.

Is there a relay somewhere that might have got damaged when the roof crimped the wire that could cause damage the chimes as that hasn't gone away. I suspect that the rain started twee problem and then coincidentally me playing with it cause the wire to get stuck.

Still not sure how this relates to the climate control not working though.
 

·
Registered
Joined
·
8,808 Posts
ACC will go to manual mode if STC (roof control module) sends "roof not closed" (open) signal to I-Bus.

I check all roof sensors with TECH2.

You can close (and secure) roof manually, owners manual tels you how-to.
For that you need 8mm allen key and wheel bolt wrench (both are in tool box).
 

·
Registered
Joined
·
34 Posts
Discussion Starter #5
Thank you for replying. That's good news really. It makes sense of the whole situation, at least I can just narrow it down to a sensor and I'm pretty sure it's obviously the one that got wet.
I will get to working on finding someone with a Tech2.

Appreciate the swift replies, honestly. Post on another Saab forum a few days ago with hardly a look.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #6
.

https://i.ibb.co/NFPT19d/20190721-132417.jpg

This is the side/area that had water soak in through the roof. There is a sensor here, I believe that might have been damaged. Is this the 6th bow?

I have taken the time to look at the roof diagrams in the wis but I cabt quite work it out.
I sensor appears to be attached to a cog with a tense wire on it.
 

·
Registered
Joined
·
8,808 Posts
Do not change any sensors randomly, they are expensive and there is 16 sensors total.
Get TECH2 and run sensor test. It will show bad sensor(s) with blinking.
You have to erase all DTCs after sensor(s) change before roof works as it should be.
 
1 - 7 of 7 Posts
Top