SaabCentral Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
First time poster, long time reader.

I have a 2004 9-3 linear and one day I hit the remote lock button over and over as one of my riends tried to open the back passenger door and I locked it on them. After a doing this the system failed. I checked the car and saw system lock failure message. Ok, turn off car, back on everything was good.

Then one day the message popped up again and the passenger front door lock would not work from the remote or the car. I said forget it, it's just a lock and proceeded to drop the windows down to get air in. The passenger window will not work!

So the passenger front lock and window won't work. I have:

  1. Checked the fuses
  2. Unpulled the battery and reset
  3. Unplugged the black plug to the passenger front door
  4. Messed with the handle
Can anyone tell me what I need to do? I am very handy.
 

·
Registered
Joined
·
168 Posts
First time poster, long time reader.

I have a 2004 9-3 linear and one day I hit the remote lock button over and over as one of my riends tried to open the back passenger door and I locked it on them. After a doing this the system failed. I checked the car and saw system lock failure message. Ok, turn off car, back on everything was good.

Then one day the message popped up again and the passenger front door lock would not work from the remote or the car. I said forget it, it's just a lock and proceeded to drop the windows down to get air in. The passenger window will not work!

So the passenger front lock and window won't work. I have:

  1. Checked the fuses
  2. Unpulled the battery and reset
  3. Unplugged the black plug to the passenger front door
  4. Messed with the handle
Can anyone tell me what I need to do? I am very handy.
I have the same car with a similar problem, every now and then the passenger front door lock doesnt work. But it is too intermittent so i have just dealt with it. My fuses are fine and the battery has been disconnected for a number of reason so it isnt that. I am curious to what the problem is, maybe it's the same one?
 

·
Registered
Joined
·
8 Posts
Mine just did that today for the first time as well - funny you should post this. I just played with it for a few minutes and it went away. *shrug*
 

·
Registered
Joined
·
88 Posts
Its gonna go away after a little. Take out the car battery for an hour and put it back in. I had this happen to me numerous amounts of time so its nothing to worry about. Saabs go crazy and then fix themselves....weird trust me. I had it fix itself so many times and break itself down.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #5 · (Edited)
So I take the door panel off, cleaned the window motor and turned the car on to test it..it worked, BUT backwards!
Pressing down makes the window go up and vice versa. So I unplug it, flip the motor in the case and nothing (still connected to the leads). No power mirrors, no windows, or locks.

I only had it working one time, never again. I have checked the motor that it is connected and changed fuses...but it's weird. Why did it work once & backwards at that?
 

·
Registered
Joined
·
12 Posts
i have the same problem with the lock on my passanger door. Sometimes won't lock- never a reason behind when and why. It tends to always happen when someone manually locks and then unlocks it (friend rests arm and locks it) but otherwise just randomly.

Never had the window problem, but now that my regulator went I wouldn't know
 

·
Registered
Joined
·
52 Posts
Door locks and window

I know this is an old thread but I have an 06 9-3 sedan with the same problem. Sometimes the PASSENGER front window and door lock won't work at all. Then sometimes the window works and the door lock doesn't. Also every now and then both the window and door lock will work perfectly. Because there are times that both lock and window work perfectly, I'm 99% sure it isn't a problem with either the motor or actuator. when they do work they work exactly as they should. I cleaned the lock button one time because it had gunk inside of it and all of it worked for a day. Then back to intermittent. I've been told it's either a bad ground, a bad switch or water/humidity somewhere in the wiring. Some say it's one of the many modules. Maybe even the drivers door control unit. Has anyone solved this problem if so please post the solution. Thanks
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #8 ·
I know this is an old thread but I have an 06 9-3 sedan with the same problem. Sometimes the PASSENGER front window and door lock won't work at all. Then sometimes the window works and the door lock doesn't. Also every now and then both the window and door lock will work perfectly. Because there are times that both lock and window work perfectly, I'm 99% sure it isn't a problem with either the motor or actuator. when they do work they work exactly as they should. I cleaned the lock button one time because it had gunk inside of it and all of it worked for a day. Then back to intermittent. I've been told it's either a bad ground, a bad switch or water/humidity somewhere in the wiring. Some say it's one of the many modules. Maybe even the drivers door control unit. Has anyone solved this problem if so please post the solution. Thanks
I have since given the car to my son and he just got ride of it, but I took it to a Saab mechanic here. A hole in the wall shop that specializes in Saabs. They replace some modules and wiring I think on the passenger side. It worked great, then it acted up again off and on, then it just went away and was fine. I do recall unhooking the cables, cleaning them and then putting it back. Maybe that was the fix, but hey it's a Saab and you get funky things like this. I suggest cleaning the connections.
 

·
Registered
Joined
·
1 Posts
Guys, I had same problem for months, window and lock on passenger side wouldn't work, im familiar with saab quirks which is why I put looking into it off for so long but I just fixed problem in literally 15 mins, behind door panel there is a single wire harness plug that controls both, mine had came unplugged. For those of you with intermittent issues confirm the harness is securely plugged in.....just a thought! I'm freaking happy right now! Lmao
 
1 - 11 of 11 Posts
Top