SaabCentral Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
So today when i tried to put the top back up, it stopped with the back of it up in the air, when i push on it it will go down but it wont lock on the back, even when i push down on it, anyone know how to remedy this? Im not very experienced with Saabs so any info would be appreciated, thanks!
 

·
Registered
Joined
·
18,932 Posts
Start by using the advanced search feature and search this forum for "shear pin". Look at the photos and then to check make sure yours is OK. If not, repair it. If it's OK, report back.

Any messages on the SID?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Thanks, i'll definetly check that out, the only message i got was to check soft top, nothing specific just enough to let me know that the car knows something is wrong.
 

·
Registered
Joined
·
18,932 Posts
The actual code/problem is stored in the top computer and requires a Tech II (dealer or indy who knows tops) to access.

Since you have a 9-3, it's also worth checking the hydraulic fluid level. There are instructions in the owners manual.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
I actually took it to the dealer i bought it from and he found that the sensor that allows the last part of the cycle to complete was out of place a little and wasnt being activated, we put it back were it can be pushed in by the latch and it works ;ol; im so glad thats all it was lol, thanks for the help though bobsaab, i appreciate the reply. I think other people on this forum might be having a similar issue so i hope this is something you can all check out if you have a similar issue.
 
1 - 9 of 9 Posts
Top