SaabCentral Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2003 9-3 Linear that runs and drives but has electrical issues that I don't have the time to dive into. As of right now it's a complete car and I'm offering any part to anyone who wants it for a fair price. The clock spring, rear calipers, passenger front fender, and (I think) the ECU are all bad but other than that everything else is ok. Body is solid other than front passenger fender. Black exterior/ black interior. Power everything, heated seats, sunroof all work. Original jack is missing. Tranny was replaced last year. Wheel bearings, gas cap, and tranny speed sensor are brand new. Original wheels with 1 year old snow tires. Radio buttons are worn and whoever owned it before me made a mess of the stereo system but I believe all speakers work. Mechanically solid, cosmetic rust on frame and underbody components. I'm willing to pull the drivetrain if needed. Let me know what you need and I'll pull it, weigh it, and calculate shipping from there. I want to part this thing out as quickly as possible so prices for all parts are low. If you want the whole car to restore, I'd do that as well. I hate to see this thing go but I hope that someone can put the parts to good use and keep their 9-3 going. Pictures available upon request.
 

·
Super Moderator
Joined
·
9,686 Posts
I really need the driver's front seat airbag sensor and connector. It clips onto the right side seat rail towards the front - I need the sensor and car side harness/connector. My connector broke:

View attachment 280451
 

·
Registered
Joined
·
64 Posts
I really need the driver's front seat airbag sensor and connector. It clips onto the right side seat rail towards the front - I need the sensor and car side harness/connector. My connector broke:

View attachment 280451
You can always use Neo too.
 

·
Super Moderator
Joined
·
9,686 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #10 ·
How is the condition of ur SCL module?

Sent from my RMX1971 using Tapatalk
Sorry for the late response my emails from the forums were going to my spam folder. The SCL does work but I believe you'd need a tech2 to pair it to your vehicle. If that's something you can do just let me know and I'll pull it for you.
 
1 - 13 of 13 Posts
Top