SaabCentral Forums banner

tps

  1. NG900 & OG9-3 Workshop
    Anyone know what size the bolt is or the bolt part number? I know it's long and thin but it's missing both. Hence, it disconnected and it's taped together for now. I don't have a garage at my apartment so I don't have random bolts hanging around. Thanks,
  2. Saab 9-2X, 9-4X & 9-7X Workshop
    Hi I recently did some work to my 2007 Saab 9-7x. 5.3 v8, 118-000 km. I was receiving a code for the Throttle Positioning sensor (TPS) being Off. Check Engine light On. No other codes at the time. After some reading, and my mechanics advice to remove the throttle body and cleaning it to see...
  3. NG900 & OG9-3 Workshop
    I picked up a P1171 code yesterday on my drive home. This morning on my drive to work, I was watching the live data to see if there was anything out of the ordinary. Three things I noted: 1) TPS (Throttle Position Sensor) would only get to about 48% at WOT (Wide Open Throttle). I checked...
  4. 9000 Workshop
    Hi, I have a 9000 Saab 2.3 Aero 5sp manual... Started it up this morning, drove it for about 2 minutes down the road, went inside my parents place, came back out 1 hour later and it would only turn over, I checked the main relay, fuel relay, fuel pump is working... I checked to Check Engine...
  5. NG900 & OG9-3 Workshop
    My 900s often takes a half dozen or so turns of the key to get started and running. It immediately starts, but then only runs for a couple seconds and then dies. I'm thinking this may be a fuel pump issue or TPS? Once it starts and stays running for a minute or so it's fine for the rest of the...
  6. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Check engine light only came on in the past month or so. It is intermittent and will come and go on a day to day basis. Longest it has stayed on is 2 days. Lately it will even go into LIMP home mode; which ABSOLUTELY SUCKS! Car is a 2010 9-3 2.0T. Car has had the following symptoms and they...
  7. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Hello group. Newbie here and pretty green when it comes to really working on cars. I have a 2006 9-3 2.0T combi. Recently went into a temporary "limp home" mode and pulled 2 codes P1681 and P0223. From other threads, most everything is pointing to a bad TPS but others are saying it could be...
Top