SaabCentral Forums banner

temperature sensor

  1. SAAB 9000 2.3T 200hp sensors

    9000 Workshop
    Dear SAAB lovers, My father gave me his SAAB 9000 CD 2.3 FPT (200hp) (which he bought it new back in 1995) with 160k. Although it is in a very good condition, I had to go through some repairs. So I replaced all the rubber hoses (water, charged air, vacuum) with silicon and Bypass valve all...
  2. 2001 9-5 Temp gauge doesn't work on cold start with P0117

    9-5 Workshop
    Hi everyone, I got my thermostat and coolant temp sensor changed about a month ago. Since last week, on cold starts the temp gauge is not working and I get cel p0117 for low voltage on coolant temp circuit. However, after I drive the car for a while and restart, the gauge works fine. I am...
  3. Coolant Warning

    NG900 & OG9-3 Workshop
    Hey All, I get a warning on my SID display indicating I need put more coolant fluid in. I checked my coolant fluid and it is at the right amount. I was told I could possibly need a coolant flush, but I don't think that's the case. It doesn't look dirty or stagnant. My theory is that it could be...
  4. A/C problem

    NG900 & OG9-3 Workshop
    So, recently i've been having an issue with my temp controls. If i use the auto setting, say at 70, and its much hotter than that, the A/C wont kick on. But, if i do a manual setting at Low, and crank the fan up all the way the A/C will start to work fine. So, i dont think the A/C is busted, or...
  5. Outside Temp Sensor

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Hi, Last week a tractor-trailer blew a tire in front of me and my only option was to run it over because there wasn't enough time to stop and I couldn't swerve in to the other lane. When this happened it pretty much destroyed the plastic under the front bumper and my outside temp now only...
  6. High Intake Air Temperature sensor (3 wires?)

    NG900 & OG9-3 Workshop
    Ok, so I have quite an explanation ahead, but If you have any experience with this sensor or with sensor wiring in general, I would greatly appreciate your input -- thanks in advance! A few weeks back, I got a CEL and autozone read it as a "high intake air temperature" code. Well, my haynes...
  7. Strange A/C Issue

    NG900 & OG9-3 Workshop
    Lately my A/C has been cutting out while driving on the highway. When it happens the temperature gauge goes from its normal "9 o'clock" position to not even registering. If I pull over, shut down the car, and restart the A/C works but the temperature gauge will only register slightly above the...
  8. Heat sensor replacement?

    NG900 & OG9-3 Workshop
    Hello all! Now that the ACC has been fixed, again, I have a different issue getting cold air to blow. It appears something is wrong and my SID is not displaying the correct outside temp. It's in the 90s here now, and the temp display changes constantly to show the outside temp, then random...
Top