SaabCentral Forums banner

slow

  1. Saab 9-5 2.0t loss of power

    9-5 Workshop
    Hey! I just bought a saab 9-5 2.0t 2005 mod to see if i can get it back on the road again. The car starts and runs fine, but when i go to accelerate is super slow. It feels like it has no power at all. It has no lamps in the dash and it has no problem getting up to 100 kph, but it takes forever...
  2. 2008 Saab 9-5 Acceleration Problems

    9-5 Workshop
    Hello all, I recently became the excited new owner of a sleek 2008 Saab 9-5 in Titan Grey, an amazing upgrade from the 2004 9-5 Linear I was sporting before. Unfortunately, taking ownership of this car has caused me to join the "9-5 slow acceleration/low boost" club. Here's the issue: The A/C...
  3. Slow off the line

    9-5 Workshop
    Hi all, Bit of an on going problem with Mum's 9-5 regarding slow acceleration. Basically, it is an intermittent issue where the car will be very sluggish off the line, and only gets moving after roughly 3000 rpm. Once moving along, the slow acceleration is not as noticable, however it is still...
  4. coolant leak, sluggish, turbo wont go all the way

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Hello again guys, Fixed my previous problem with the dreaded gearbox malfunction turning out to be a Crankshaft Position Sensor but still have a coolant leak even after the water pump had been replaced. Very weird one guys, the coolant tank smells if petrol! gas to you Americans :) but that...
  5. Intermittent sluggish acceleration

    9-5 Workshop
    Hi all, I've had a search through the forums but couldn't find anything that directly applies to the problem I've got with my Mum's car. It's an '06 9-5, 2.3t. Recently, it's had a problem where it will intermittently become very sluggish, to the point where it's dangerous when pulling out...
  6. Slow start/firing

    NG900 & OG9-3 Workshop
    I have a 1999 9-3 with 177k on it. After having to get a jump start my Saab is slow to start. It has to crack several times before actually starting up. Any ideas? Could it be the crank position sensor going bad?
  7. slow speedo

    C900 Workshop
    A little history first - when I bought my 'vert, the speedo needle was stuck behind that little pin that should normally keep it at zero when stopped. It looked like the tip of the needle had broken off (I found it at the bottom of the instrument cluster) but just enough of the needle was there...
Top