SaabCentral Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. 9-5 Workshop
    Background: 2010 9-5 Aero 2.8T AWD, bought a few months ago. 1257XX miles. I have been getting 22MPG around town and then 30MPG on the freeway. Timeline: 1. On startup it has always smelled like it is running rich. On the information display it says that it is running 3.0GPH right after...
  2. C900 Workshop
    Hi, I have a 1990 900 Turbo (Full pressure) with Bosch Jetronic ignition. I've been having some running issues - well, the car drives ok, but the idle is not even, the fuel consumption is very high and there is often a wet sooty discharge comes out of the exhaust when idling. I've replaced...
  3. 9-5 Workshop
    First of all I just want to say thanks to this forum for helping me out with many questions that I've had about my Saab, I just recently registered but I have been roaming the forums for awhile before that. Anyway, I have a 1999 9-5 2.3 Auto (205K) that I bought for my girlfriend about 8 months...
  4. C900 Workshop
    Hello, I am fairly new to Saab's. I purchased mine about 3 years ago, took 2 years to restore it, then 5 months ago had a shop install a used motor with approx. 115k miles into the car. Since then it has run without issues for 2000 miles, until this past weekend. Thats when the CEL came on...
  5. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    I own a 9-3 cabrio (2006 model) 150hp Tdi Saab. In mid June I bought a BSR ppc tuning kit upgrading to 184Hp and 412 Nm torque. I also purchased and fitted a JR sport filter. The car ran great for a couple of weeks, then suddenly it went in limp mode and I had to regenerate the PF. Now, after...
1-5 of 5 Results
Top