SaabCentral Forums banner

rough

  1. Cel code p0300???!

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    hey guys. i have a 2006 9-3 arc with 196k miles. I noticed a Check Engine Light today when i left the starbucks parking lot and i went straight to autozone to get it checked. It was P0300 (random misfire detected). What might be the cause of it? Things that are worth mentioning that might be...
  2. Extremely hard clutch and stubborn shifting when weather is hot/car is warmed up

    NG900 & OG9-3 Workshop
    Car: 94 NG900 SE Turbo Ever since my dad and I changed out the clutch I have been experiencing problems when the weather is hot or if the car is driven for long periods at a time. The clutch action feels extremely hard and "sticky" (The best way I can describe the feeling is it's almost like a...
  3. SAAB 9-5 AERO idle problems

    9-5 Workshop
    Hello! I have lots of problems with my Saab lately. I add 2 videos. https://youtu.be/ZnVM3QqX1Bw https://youtu.be/89dIFehQjW8 Car runs fine on road. But when idle or in D stop i feel rattling feel on steering wheel. Last week i found that oil cap in with oil.... I see i have updated PVC...
  4. Running very rough when hot

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Hi Folks, I have a 2003 9-3 ARC that runs well when cold but like it is on 2 cylinders when it is hot. It also goes into limp mode - caps out at ~2000rpm. Engine has done 120 000 km and compression on all 4 is around 184psi. I have; - replaced the plugs - replaced coil packs - cleaned...
  5. Pulsing when accelerating

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    I own a 2010 93 1.8t auto which has Maptun stage 1 (220bhp) software on it. I have been trying to rectify the performance issue I have with the car for years now, but as yet no luck. The engine has a slightly rough idle and will sometimes feel like it is losing power or pulsing when...
  6. 2000 Saab 9-5 Aero Wagon Start then quickly dies

    9-5 Workshop
    Today as I was just pulling into my parking spot at work my car suddenly died. I decided to try and start back up and it started just fine, but after only a second or two it died. I tried this again a couple times all with the same result. I then started it and promptly pumped the gas pedal. It...
  7. What is this part? And this one?

    NG900 & OG9-3 Workshop
    http://s1254.photobucket.com/user/cjcopp/media/IMG_20140530_203544_zpsca2a5d6b.jpg.html?sort=3&o=8 which fits into http://s1254.photobucket.com/user/cjcopp/media/IMG_20140530_203448_zps0de5bae7.jpg.html?sort=3&o=9
  8. Viggen failure Help!!!

    NG900 & OG9-3 Workshop
    Hi all, I haven't been on here in a long time, anyway. My brother was borrowing my viggen a couple of days ago and it has blown off an intercooler pipe. Not knowing what had happened he got it to his mates place, only a block away. I have had a quick look, saw the lower pipe disconnected...
  9. Rough idle when cold 93 2.0t 2001 b205

    NG900 & OG9-3 Workshop
    Ok ok so here we are after weeks and weeks of trawling the net and searching for an answer. My 2001 Saab 93 2.0t t7 is playing up has been for about a month not getting any worse but not getting any better. If I leave her over night or for a long period 6-8 hours plus she starts perfect but...
  10. Engine problem on a 1994 9000CSE 2.3fpt

    9000 Workshop
    My car is a 1994 9000cse 2.3 fpt with an Aero 5 speed swap. I was on my way down the highway when my I started losing speed and gave it a little more gas and then the boost gauge read full boost but my rpms were still low. Right after that I put the car in neutral and it stalled. I put it in...
  11. Stalling problem on start up

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    My 07 2.0T with 38k miles on it has started to stall on me when I try to start it. It turns over fine and starts, then immediately runs rough, and dies. Sometimes I'll have to start the car 2 to 3 times like this before it continues to run. After if finally starts, It runs great, no...
  12. Two problems. No heater and runs terribly when cold

    C900 Workshop
    Hi All, I've decided it's time to finally try and sort out some things with my 1986 900i. Fixed the thermo fan today but I'm still having trouble with the car when it's cold. Essentially it runs like a total dog. It doesn't want to accelerate, it's jerky. I drive to the bottom of my street and...
  13. Running rough/missing

    9-5 Workshop
    Have a 1999 2.3l 95. CEL on with rough running when car died completely and wouldn't start. Replaced DI and car started but still rough idle. Cleaned throttle body but stil rough. Replaced cps and car still rough. Replaced plugs (all four black indicating rich fuel). Car still running...
Top