SaabCentral Forums banner

rough idle

  1. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Ive been fighting a misfire in cylinder 6 on my 08 93 aero 2.8 v6 fwd. Ive replaced the coil, sparkplug (gapped at .034), injector, and injector wiring harness. I know im getting spark out of the coul and plug and im not sure where else to look. The problem is mostly persistent but every once in...
  2. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Hi everyone. I have rough idle at startup. I have a video in the link below. I have read that newer Saabs (07-08) have had this issue and it was bad valves. I'm hoping that's not the problem as I think it may be too costly to repair. Should I start with new plugs and go from there? Thanks...
  3. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Hello, I have a 2004 Saab 9-3 Linear Automatic with 192,000 miles. I have read many posts on this site to try to identify my issues below but I wanted to see what your thoughts are. At this point in the cars life I don't want to spend too much trying to fix the issue. Roughly 5 years ago I...
  4. 9-5 Workshop
    One evening my car started running rough, but I had to drive across town to pick up my kids so I pressed on. By the time I got to them it was worse, but still moving. Shortly after getting the kids, it overheated, the steering got real tough, oil overflowed from the oil fill cap, and the...
  5. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    My 9-3 (2005), check engine light has been on for a few days. Yesterday it ran real rough and I could smell gasoline. Today it's running fine, but I had a mechanic clear the codes and then recheck it after the light returned. He said it's coming up "injector circuit in 1,2,3,& 4." Any...
  6. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Hi, I have a 2006 9-3 2T wagon. I bought it for my son as a first car, and had nothing but trouble after about 4 months of owning it. My first problem was getting the codes P0204, P0203, P0202, P0201 & P0245, accompanied with the gas smell, white smoke and the other standard issues. I took it...
  7. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Here's a link to a video I took last night. This only happens on start up, immediately after the initial crank's RPMs drop to normal idle speed. You can only hear/detect this at idle. Drive for about 2 minutes & it warms up & it's gone until the engine cools off again...
  8. 9-5 Workshop
    Hi, I recently (6 months ago) bought a 9-5 2002 model with about 120K to replace my old 9-5 1998 with approx 250K which still ran very smoothly but was falling apart interior etc. after a hard life. The new one has lots of power but is vibrating when taking off and idles a bit rough when put...
  9. NG900 & OG9-3 Workshop
    Hi all, let me get started by saying I'm not posting to waste your time. If I had found an answer up until this point I would not be posting here. My 2002 Saab 9-3 SE has been driving me crazy, lately. It has been idling very rough and misfiring while running. It runs so rough, to the point it...
  10. New Member Introductions
    Hey Everyone ! I am really excited to be a part of the community. I do need some help. My '00 95 2.3t is having some idle and smoking problems. The car drives fine at speed but when ever i come to a stop, she idles roughly. Almost so bad to where i feel like it will die on me. Not only that...
  11. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Hello All, I've been getting an error code P0638, which kind folks here tell me and research on this board denotes dislodged pins in connector H42-2. However, I am unable to find any information on the location of this connector (besides somewhere under the battery tray). Can anyone please...
  12. 9-5 Workshop
    I an having idle issues with my Saab 9-5. I replaced the MAF today and it hasn't changed anything. So now I am wanting to try the MAP. However, I am not sure I know where that is located. I am being lead to believe that it is what's shown on the attached file. However, when I look up the part it...
  13. 9-5 Workshop
    My daughter's 2001 9-5 V6 has just started running very rough with a very loud knocking noise. At first I thought it was the DIC because I was having an intermittent problem with the car acting as though it was dropping out a cylinder then catching itself and running fine again. This knocking...
  14. NG900 & OG9-3 Workshop
    Man, I'm going to get a ton of flack for asking a really vague "what's wrong with my car" question, so please make the flames entertaining for all, OK? :P 2001 9-3 with 175k miles... My car developed a subtle rattle from the engine between gear shifts under higher acceleration (merging onto...
  15. 9-5 Workshop
    2 weeks ago I got rear ended at a stoplight in Charlotte (about 25 miles from home) by a Mitsu Montero Sport. I was stopped, they were stopped, and apparently, they thought the light had turned green... I had not moved. Banged up the bumper and liftgate, destroyed a parking sensor, and...
  16. 9-5 Workshop
    Hello all, this is my first post. I have a 2000 Saab 9-5 Wagon 2.3L Turbo. I have tried doing google searching and all else (except going to a mechanic) to try and figure out the best way to do this. I went and bought a bottle of sea foam that I want to put through the intake manifold in hopes...
  17. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    My 03 vector with an 04 engine in it is intermittently having a rough idle that in some cases the car will stall completely. Currently, i have a CEL for a random intermittent misfire and have had a lean code before as well. The acceleration is sub par and i get engine stumbles. The one confusing...
  18. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    As mentioned in a litany of threads on the board, MY2007 - MY2011 9-3SS 2.0T have an issue with accelerated wear on the intake valves. The prevalence of this issue is unknown, but SPNA Technical Assistance recently expanded the bulletin regarding the issue to include Model Years 2010 and 2011...
  19. 9-5 Workshop
    Hi all, I'm having a plethora of issues with my 2.3t and don't know where to go from here, I'm hoping someone has some ideas. Here's what's happening: I drove the car home and parked it. I came out a few hours later and tried to start it. It cranked but wouldn't start. I determined the problem...
  20. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    A couple of days ago, the "Battery not charging" message popped up on my SID. Searched the forums and people say this means it's a bad alternator. Strange thing is that this message doesn't always come on. It just happened 4 times during 3 days. then everything went back to normal. Just to be...
Top