SaabCentral Forums banner
oil pump
1-8 of 8 Results
  1. NG900 & OG9-3 Workshop
    I've got a '97 Saab 900 SE Turbo with 350k miles. Just replaced the head gasket on it. Now that I've got it back together there's a noticeable whine coming from the oil pump area. The whine is still there even with the serpentine belt off. (Video link: https://vimeo.com/218544188/f86017032e)...
  2. C900 Workshop
    Hello all, I have a 1988 900 turbo convertible with 60k miles on it. For the past few months I have had a high pitched scream come from my engine right when it starts, and only right when it starts. I got the belts tightened, and placed the chalk mark on the crank pulley. The noise...
  3. NG900 & OG9-3 Workshop
    Hey guys, I've been having some major oil pressure problems and have decided to change out my oil pump next weekend. Aside from the oil pump its self, are there any other parts (O rings, valves, gaskets, etc) that I should order and replace while I'm doing this? Its a 98 saab 900 SE Turbo...
  4. NG900 & OG9-3 Workshop
    HI, I'm new to this forum. My "new to me" Saab 900's CEL came on i have no idea how to read the codes, it had flashed on and off everyday for the 3 weeks that I had owned it, so thinking nothing of it I kept driving. I had noticed a loud ticking noise at about 2000 rpm. It sounded like injectors...
  5. 9-5 Workshop
    I own a 1999 Saab 9-5 v6 and I plan on replacing the Crankshaft seal and also the oil pump seal, my only problem is that I dont know if the v6 has a Oil Pump seal like the 4 cylinder engines. I've search eEuroparts, thesaabsite, and a couple of other sites and cant find anything about it. Can...
  6. NG900 & OG9-3 Workshop
    Ordered the parts after pulling the wheel and belt cover and seeing that it must be the OilPump Seal. Question is once I get the HarmBal bolt off will it and the pulley just slide off or does it need persuasion? Have a HBalancer puller, but (and I shoulda took a picture while i was under there)...
  7. 9000 Workshop
    The other day I was driving to school in my 1994 Saab 9000 CSE Aero Turbo and all of a sudden when i tried to accelerate my engine would rev but no power to the gas. It seemed like it slipped into neutral but it didn't rev like it was in neutral, it revved as if it was in drive. I pulled over to...
  8. 9-5 Workshop
    Hi, everyone, I wonder if anyone can advise me, I have a 9-5 Aero Estate, 2001, with 162000 miles, and although it is running ok, when it starts, almost every time and certainly when from cold, there is a light knocking as though the oil isn't reaching all the parts it should be lubricating...
1-8 of 8 Results
Top