SaabCentral Forums banner

misfire

  1. OBD Emissions Fail

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    I have a 2001 93 that just failed emissions ;oops: and I have the codes that caused the failure. About 2 yrs ago I replace the original engine with an Ecopower 2.0 Turbo. I've been looking up the codes online as I want to attempt to fix these gremlins myself, the codes are as follows: P0455...
  2. 2.5 v6 misfires

    NG900 & OG9-3 Workshop
    I ve been trying to fix this Saab for 2 months now and a couple of days ago it started running like crap. The CEL was flashing and ran like a Harley. When I pulled the codes it gave me random misfire and four of the cylinders and nothing else :confused:. I would greatly appreciate it if someone...
  3. '94 900S 2.5 V6 Running Problems

    NG900 & OG9-3 Workshop
    My 17 year old son drives a 900S and overall it's been a very reliable $600 car, but lately it's been running poor and we've invested that much again in parts. It starts great but you can tell there's a miss even at idle. On the road it is very sluggish and has no power. The cat was plugged so...
  4. Extreme idle

    NG900 & OG9-3 Workshop
    Experiencing extreme rough idle, car fails to start 1/5 times, check engine light on. The problem occurred my on morning drive to school which is 10 mins city driving. The car had been working fine beforehand , never had any idle issues. I noticed that morning while warming up the car I felt a...
  5. Wow unknown problem with my saab!

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    i recently purchased a 2004 saab 9-3 with 85k miles. the car ran perfect until earlier today it started jerking on the highway. at first i felt like the transmission was slipping b/c as i was giving it gas it would start like vibrating (felt like i was going over rumble strips). it started off...
  6. 2002 9-3 Blown motor?

    NG900 & OG9-3 Workshop
    Sadly my 9-3 may have a blown head gasket? Thought Id post this a see what the saabies think. It started on Christmas Eve when I was driving in the thru way. It started running really rough. I thought it was a bad plug or a bad DI cassette but I replaced the spark plugs (with NGK's) and checked...
  7. Dead DIC ?

    NG900 & OG9-3 Workshop
    DIC Failure ? I bought a 9-3 1999 2 month ago. I was enjoying my new ride.. A week ago, I was on the highway driving at 150KM/h when a cylinder started misfirering.. really bad. Scan result : PO304 (misfire cyl 4) PO171 (system tooleanbank 1) PO133 (02Sensor Slow-Response) What is...
Top