SaabCentral Forums banner
loss of power
1-13 of 13 Results
  1. C900 Workshop
    Hello everyone, Very inexperienced owner over here but I'm hoping for some pointers.. I've been having an intermittent issue with my '93 900s (non-turbo) manual sedan, owned since August last year and enjoyed problem-free for 4k miles, mostly highway.. I've been doing some more city driving the...
  2. 9-5 Workshop
    We've taken our 2001 saab 9-5 SE 3.0T (lol) V6 on a seattle-to-LA road trip every year for a few years (2) perfectly fine. The third year, the car made it about 6-8 hours into oregon, started misfiring, and died shortly after. To make the story short, we rented a car to get to LA and I picked up...
  3. 9-5 Workshop
    Hey! I just bought a saab 9-5 2.0t 2005 mod to see if i can get it back on the road again. The car starts and runs fine, but when i go to accelerate is super slow. It feels like it has no power at all. It has no lamps in the dash and it has no problem getting up to 100 kph, but it takes forever...
  4. 9-5 Workshop
    Hi, As if things couldn't get worse. My car has been driving around fine today, and then when I leave work there was a hesitation like a misfire. As I started driving it seemed to occur once the revs were over 2k but the car would accelerate slowly anything under 2k. Then it just kept getting...
  5. 9-5 Workshop
    Hey everyone! I am going to apologize in advance for the really long post.. I just want to give as much information as I possibly can! My car: 2008 9-5 2.3t 188K miles I have been having really bad issues with performance/boost. I used to be able to put the pedal on the floor and the car...
  6. C900 Workshop
    Hi there everyone, I am new to this forum as well as new too Saabs. I recently purchased a 1990 Saab 900 sedan for $700. Have been driving it about a month and I have to say I really like it. About a week ago I parked it and when I got back in it it would start and then stall until it wouldn't...
  7. 9-5 Workshop
    I had a strange occurrence with my '02 9-5 Linear this weekend that I figured I'd tell you all about. I was on the highway here in NH, doing about 75, in 5th gear with the cruise control on when I lost power and had to pull over. When I pulled over the car just died. Doing research on here, I...
  8. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Hi Saab-Lovers, I have had my 1999 Saab 9-3 for about two years now. Up until recently, like 3 months ago, it has been running fine. I did have it parked through the winter as I live in a snowy area and could just walk to work. I had it smogged in March and the tires changed. Since the tires...
  9. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    2003 9-3, @85,000 miles. During trips over 30 or 40 minutes, car lost power during acceleration after stopping. I'd drive at highway speeds, everything would be fine, then when I got off the highway and came to a stop or slowed down significantly, the car just wouldn't 'GO'. Get off the...
  10. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    4 weeks ago my belt tensioner failed. I put it the garage and had a new tensioner, crank shaft pully and fan belt replaced. While the mechanic was on I got him to change the timing belt and service it too. When I got it back it had a really rough idle, engine shaking alot. However it drove...
  11. 9-5 Workshop
    I have installed a 1000 watt aftermarket audio system in my 2001 Saab 9-5. I have a capacitor attached to prevent the headlights from dimming and losing so much power but it seems to have made no difference. The capacitor is correct for the sound system and all wiring is correct. Now even with...
  12. 9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    I have a 2003 9-3 Linear. This morning I went to start it and it would not start. The check engine light was on with no SID indications. I jumpstarted it and drove it for a second thinking I may have left a light on and the battery died. It was very sluggish and produced probably 30% of its...
  13. C900 Workshop
    sometimes when pressing the gas it has no power gain. Sometime in the AM when im driving it feels liek it boggs out. Today on the way home from work hit the highway just fine. At a stop lite when i went to accelerate it had NO POWER. No matter how hard i pressed the gas. I let off the gas...
1-13 of 13 Results
Top