SaabCentral Forums banner

limp mode

  1. Issues With Shifter Linkage

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Kind of new here, hope I'm posting in the right section. About six months ago, my 9-3 2.0t from 2007 had the shifter cable disconnect from the transmission. I examined the part and after some research found that the bushing connecting the two components was missing. I went online and didn't...
  2. LIMP Mode: 1999 Turbo Saab 9-3 2 Dr Hatchback 63K miles

    NG900 & OG9-3 Workshop
    Hello - any & all help is much appreciated! None of the threads I have seen Anywhere (here, youtube, other Saab sites, etc) show pictures that look like my engine. They all say to 'Reset the throttle Body' - but mine doesn't look like what they show. I have attached pictures. I would also...
  3. Will my ecu unmarry if I disconnect it?

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Hi, recently my 2003 9-3 went back into limp mode after not doing so for about a year. I started to look for a solution and found out that there's a defect where the seals on the ecu plugs will contract in cold weather (which would make sense as it's been in the snow lately) and the solution is...
  4. Is my car in limp mode?

    NG900 & OG9-3 Workshop
    My check engine light has been on for a while but it was running fine. A week ago I started losing acceleration, a couple days ago I can hardly drive it because it takes so long to get up to 30mph. I have a saab 93 2002. I checked the codes and p1107 and p1106 came up. I know they're sensors...
  5. Almost NO Acceleration after engine warms up... HELP! ('03 9-3 2.0T)

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    2 days ago, my 2003 9-3 2.0T started accelerating poorly (like I can't even speed up to get into traffic) after it's warm. For the first 10 minutes (until the temp needle reaches the middle) it's fine. I can accelerate / the turbo gauge climbs to almost red and have full power. After the car...
  6. I mixed the coolants, Problems arose. Related?

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    So my ignorant self from 6 months ago didn't know there was a difference between the orange and green coolants. So I topped off the coolant in my 2005 9-3 with green. Seeing as it was November in Minnesota, I had no issues with cooling. Fast forward 6 months, It is now April and my car has...
  7. limp mode in cold temps

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Any ideas on what would cause intermittent limp mode with check engine light on cold days? Last year it seemed like the temp had to be below 10F to trigger the problem, but now this year it occasionally happens at 30F and below. We have tried cleaning the throttle body and a few other minor...
  8. fault code P10607 / car is in limp mode

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Hi, I have a 9-3 vector sport 2.2 diesel on a UK 53 plate. The car is in limp mode, the engine light on and is showing fault code P0107 I have just replaced the MAP Sensor, MAF Sensor and the atmospheric Pressure Sensor, but the fault is still there.:( When driving the car after clearing...
  9. 04 93 aero po638 code and limp mode symptoms

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    I was changing my spark plugs and accidently broke one of the coil pack bolts getting it out. Finished up and drove it to the store to replace the bolt and the engine suddenly kind of 'cut out' and wouldn't rev above 2500. Replaced the bolt, checked everything over, right plugs, torqued down...
  10. Funky things happening

    NG900 & OG9-3 Workshop
    Last night my gf car muffler right behind the cat came off . I drove it up on yo ramps and put the piece back in side .. When I pulled the car off the ramps the. Check engine light and gearbox light were on .. Then I realized that the auto lights were not working and the brights won't stay! I'm...
  11. starting problems +/- limp mode

    9-5 Workshop
    SAAB 9-5, 2002 linear The last couple of days i have been having intermittent problems where the display would go half-bright while displaying all warning lights (CEL, transmission, battery, bakes etc) and the car would become very sluggish kind of like limp mode. At the same time speedometer...
  12. Goes into Limp Mode on Cold Start

    NG900 & OG9-3 Workshop
    Hello, The car goes into Limp Mode while key is ON during cold mornings, and I have not even turned the engine over. Car sat overnight. It's cold this morning and it goes into Limp Mode when key is ON (I hear the ticking sound). This ONLY happens on a cold morning. It's been pretty hot...
  13. 89 9000 CD Check Engine Light

    9000 Workshop
    I have an '89 9000 cd that I did the head gasket on about 4000 miles ago. It has been running fine until two days ago when it started dying on the highway and the check engine light started coming on. I got it home cleaned the plugs ( they were black) and checked for vacuum leaks, took it for...
  14. Limp Home Mode - most likely causes

    9-5 Workshop
    OK, I need some help diagnoising a problem. Overview: 1999, 9-5 Wagon, V6, 293,000 miles. I was accelerating to about 45 mph, when I heard what sounded like air escaping a tire for about 3 seconds. I assumed I had hit something and was losing a tire. Within about 10 more seconds I could feel the...
  15. HID lights turned on check engine light and Limp mode

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    I recently installed After market HID lights on my 2005 9-3 and the check engine light came on and made my car go into limp mode. Did i do something wrong?
  16. aftermarket HID lights on 2005 9-3 HELP!!!!!!

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    I recently purchased a HID kit that fits my 9-3 the installation went very smoothly and they work very well but i pull my car out of the garage and i noticed that my check engine light is on and the car is in limp mode. Has anyone else added aftermarket HIDs? or is it my k&n air filter setting...
Top