SaabCentral Forums banner
lack of power
1-6 of 6 Results
  1. NG900 & OG9-3 Performance, Mods & Tuning
    At long last I am finally going to ask for help. I bought my Viggen last fall, and I love the car to death but it has its share of problems. It has a stage 3 JZW tune, good for about 350 horse, idk though I haven’t dyno tested it and I bought it with the tune on it. JZW has apparently fell off...
  2. NG900 & OG9-3 Workshop
    wont fully boost. i suspected its the maf sensor but i cant seem to even find one on the car. the srs light is also on. think its in limp mode? and yes iv done the basic checks anyone have any tips?
  3. NG900 & OG9-3 Workshop
    Hello Everybody, I'm new to this forum, I own a 2002 Saab 93 2.2 TiD 125Hp that has around 230K km (almost 150k miles dunno what kind of units you use...) I do most of the things I can do on my own on the car, and recently, after a diesel filter change (under the car right next to the right...
  4. 9-5 Workshop
    I recently purchased a 01 9-5 just as a beater. It has the 3.0 v6, and came with a ton of receipts. I'm not familiar with the v6 saabs, so my father took it for a ride with me and said it doesn't have as much power as it should. When starting it cold, it generally stalls the first try, but...
  5. 9-5 Workshop
    well, after my check engine light had been on a good week or so, i took it to get looked at because my turbo didn't seem to be boosting properly, it usually boost top 0.5 bars max, and between 0.4-0.6 bar min , and had been boosting 0.7 min .. the code that came up was for a random misfire.. i...
  6. 9-5 Workshop
    Let's see if i can describe the problem in English :) I drive a 03 9-5 Aero Automatic that don't feel like 250bhp, it feels like my old 9000 2,3T was quicker. Anyway, i tried to disconnect the R-hose from the solenoid valve(i suspect that the problem is the evap system) and nothing changed...
1-6 of 6 Results
Top