SaabCentral Forums banner

high

  1. High idle

    C900 Workshop
    Hi everyone, After replacing my head gasket, I'm having an issue where the car idles high, getting worse as it gets to operating temp, where the idle speed starts jumping. I've also noticed that the jumping stops when aircon is turned on (even though the compressor clutch doesn't work). I...
  2. Engine Temperature Gauge always a little low?

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Ever since I have had my 2004 9-3 conv, about 8 months, the temp guage has always stayed just below the center 9 o'clock position. I've been through the seasons with low and quite high Phoenix AZ temps. This is when it is fully warmed up when cold it goes down normally. But in the picture that...
  3. V6 2.8T (TX) - extremely high oil pressure readings ?

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Hello, I am trying to get my TXSC ready for a Stage0 tune, and did a log run yesterday. Brian says that: "The misfires are all on cylinder #5. I am also seeing extremely high oil pressure so something else is wrong with the engine. It looks like the pressure sensor is maxed out (reading over...
  4. Very high idle, tach needle not working

    9000 Workshop
    1997 9000 Aero 2.3 5spd. Just happened earlier this evening - about 3 hours after a normal work commute. I had some idle trouble a few weeks ago, removed and cleaned the IAC with carb cleaner and that seemed to fix the problem. Tonight, upon startup, the RPMs were a little shaky -...
  5. Weird Fog light problem.HELP!

    9-3 Sedan, Cabrio '04+, Combi, 9-3X Workshop
    Alright so here my problem...my front fog lights work completely fine. heres the catch they only turn on with my high beams!! if i turn the high beams off the fog lights turn off also...and if i hit the front fog light button while high beams are off nothing happens. could it be the switch...
Top